summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredmattski2022-10-25 09:21:26 +0200
committerredmattski2022-10-25 09:21:26 +0200
commit3c6f4b7b7c24804a8d28817716217bf2fc97cbff (patch)
tree28185fea73672f66f0292e36ae8d727c60430aff
downloadaur-3c6f4b7b7c24804a8d28817716217bf2fc97cbff.tar.gz
initial build
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d57fe9240332
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-audible-series
+ pkgdesc = Adds a command to audible-cli that looks for new series releases in a user's library.
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/luscoma/audible-series
+ arch = any
+ license = APACHE
+ makedepends = python-setuptools
+ depends = python
+ depends = python-audible
+ depends = python-yaml
+ provides = python-audible-series
+ conflicts = python-audible-series
+ source = https://files.pythonhosted.org/packages/source/a/audible-series/audible-series-1.0.2.tar.gz
+ sha256sums = 8081bdc71cb11c641ac33f27398ab3669505d281c7047c5a7fa1937c586e6d01
+
+pkgname = python-audible-series
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c2ed3d044e82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: mattski <redmattski at gmail dot com>
+
+pkgname=python-audible-series
+_name=${pkgname#python-}
+pkgver=1.0.2
+pkgrel=1
+pkgdesc='Adds a command to audible-cli that looks for new series releases in a user'"'"'s library.'
+arch=(any)
+url=https://github.com/luscoma/audible-series
+license=(APACHE)
+depends=(python python-audible python-yaml)
+makedepends=('python-setuptools')
+#makedepends=(python-pip)
+checkdepends=()
+provides=($pkgname)
+conflicts=($pkgname)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('8081bdc71cb11c641ac33f27398ab3669505d281c7047c5a7fa1937c586e6d01')
+
+build() {
+# pip install --no-deps --target=$_name $_name==$pkgver
+ cd $srcdir/${_name}-$pkgver
+ python setup.py build
+}
+package() {
+# sitepackages=$(python -c "import site; print(site.getsitepackages()[0])")
+# mkdir -p $pkgdir/"$sitepackages"
+# cp -r $srcdir/$_name/* $pkgdir/"$sitepackages"
+ cd $srcdir/${_name}-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}
+