summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredmattski2024-05-04 17:54:22 +0200
committerredmattski2024-05-04 17:54:22 +0200
commit516c19d968e60e60f9169ed2791e7e912217487f (patch)
tree7875c73a3b999a086c1bde72806c0b03c77a3c59
parent3c6f4b7b7c24804a8d28817716217bf2fc97cbff (diff)
downloadaur-516c19d968e60e60f9169ed2791e7e912217487f.tar.gz
Update to install method
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 10 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d57fe9240332..450607eb0385 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = python-audible-series
pkgdesc = Adds a command to audible-cli that looks for new series releases in a user's library.
pkgver = 1.0.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/luscoma/audible-series
arch = any
license = APACHE
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
depends = python-audible
depends = python-yaml
- provides = python-audible-series
- conflicts = python-audible-series
source = https://files.pythonhosted.org/packages/source/a/audible-series/audible-series-1.0.2.tar.gz
- sha256sums = 8081bdc71cb11c641ac33f27398ab3669505d281c7047c5a7fa1937c586e6d01
+ sha256sums = c634b465788ec995bf734f6f337343c2e327a80f6f11c6a66b367129cea35ad0
pkgname = python-audible-series
diff --git a/PKGBUILD b/PKGBUILD
index c2ed3d044e82..95fe94329967 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,30 +3,23 @@
pkgname=python-audible-series
_name=${pkgname#python-}
pkgver=1.0.2
-pkgrel=1
+pkgrel=2
pkgdesc='Adds a command to audible-cli that looks for new series releases in a user'"'"'s library.'
arch=(any)
url=https://github.com/luscoma/audible-series
license=(APACHE)
depends=(python python-audible python-yaml)
-makedepends=('python-setuptools')
-#makedepends=(python-pip)
+makedepends=('python-build' 'python-installer' 'python-wheel')
checkdepends=()
-provides=($pkgname)
-conflicts=($pkgname)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('8081bdc71cb11c641ac33f27398ab3669505d281c7047c5a7fa1937c586e6d01')
+sha256sums=('c634b465788ec995bf734f6f337343c2e327a80f6f11c6a66b367129cea35ad0')
build() {
-# pip install --no-deps --target=$_name $_name==$pkgver
cd $srcdir/${_name}-$pkgver
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
-# sitepackages=$(python -c "import site; print(site.getsitepackages()[0])")
-# mkdir -p $pkgdir/"$sitepackages"
-# cp -r $srcdir/$_name/* $pkgdir/"$sitepackages"
cd $srcdir/${_name}-$pkgver
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}