summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2020-10-08 14:04:18 +1100
committerPumpkinCheshire2020-10-08 14:04:18 +1100
commit10eec7801bb9df1579cba75d64d8b59ad6347f0a (patch)
treee64b8d2c413ba20306313a385fe8f3d81eaa1868
downloadaur-10eec7801bb9df1579cba75d64d8b59ad6347f0a.tar.gz
add pypi version auditok
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e8a15b25e44
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-auditok
+ pkgdesc = An audio/acoustic activity detection and audio segmentation tool.
+ pkgver = 0.1.8
+ pkgrel = 1
+ url = https://github.com/amsehili/auditok
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ optdepends = python-pydub: read audio files in popular audio formats (ogg, mp3, etc.) or extract audio from a video file.
+ optdepends = python-pyaudio: read audio data from the microphone and play back detections.
+ optdepends = python-matplotlib: plot audio signal and detections
+ optdepends = python-numpy: used for math operations instead of standard python if available.
+ source = https://files.pythonhosted.org/packages/source/a/auditok/auditok-0.1.8.tar.gz
+ md5sums = ce305a5c18fd2a472c103400a9a3b76a
+
+pkgname = python-auditok
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56c39f2e5d12
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: PumpkinCheshire <sollyonzou@gmail.com>
+
+_name=auditok
+pkgname=python-auditok
+pkgver=0.1.8
+pkgrel=1
+pkgdesc="An audio/acoustic activity detection and audio segmentation tool."
+arch=('any')
+url="https://github.com/amsehili/auditok"
+license=('MIT')
+depends=("python")
+optdepends=("python-pydub: read audio files in popular audio formats (ogg, mp3, etc.) or extract audio from a video file."
+"python-pyaudio: read audio data from the microphone and play back detections."
+"python-matplotlib: plot audio signal and detections"
+"python-numpy: used for math operations instead of standard python if available.")
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+md5sums=('ce305a5c18fd2a472c103400a9a3b76a')
+
+
+prepare() {
+ mv -v "${_name}-${pkgver}" "${pkgname}-${pkgver}"
+ cd "${pkgname}-${pkgver}"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}