summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2020-12-04 08:49:25 +1100
committerPumpkinCheshire2020-12-04 08:49:25 +1100
commitd601a06ab43026eec0a99060022e0487a571c8e7 (patch)
tree730be322fa8b96a23abaef7955cee4ffb4b70f04
parent10eec7801bb9df1579cba75d64d8b59ad6347f0a (diff)
downloadaur-d601a06ab43026eec0a99060022e0487a571c8e7.tar.gz
bump for python3.9
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD22
3 files changed, 13 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e8a15b25e44..96e57e3ab84e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-auditok
pkgdesc = An audio/acoustic activity detection and audio segmentation tool.
pkgver = 0.1.8
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/amsehili/auditok
arch = any
license = MIT
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 56c39f2e5d12..32949700fdab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,33 +3,27 @@
_name=auditok
pkgname=python-auditok
pkgver=0.1.8
-pkgrel=1
+pkgrel=2
pkgdesc="An audio/acoustic activity detection and audio segmentation tool."
arch=('any')
url="https://github.com/amsehili/auditok"
license=('MIT')
depends=("python")
optdepends=("python-pydub: read audio files in popular audio formats (ogg, mp3, etc.) or extract audio from a video file."
-"python-pyaudio: read audio data from the microphone and play back detections."
-"python-matplotlib: plot audio signal and detections"
-"python-numpy: used for math operations instead of standard python if available.")
+ "python-pyaudio: read audio data from the microphone and play back detections."
+ "python-matplotlib: plot audio signal and detections"
+ "python-numpy: used for math operations instead of standard python if available.")
makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
md5sums=('ce305a5c18fd2a472c103400a9a3b76a')
-
-prepare() {
- mv -v "${_name}-${pkgver}" "${pkgname}-${pkgver}"
- cd "${pkgname}-${pkgver}"
-}
-
build() {
- cd "$pkgname-$pkgver"
+ cd "$srcdir/$_name-$pkgver"
python setup.py build
}
package() {
- cd "$pkgname-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}