summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2015-10-02 23:12:54 +0200
committerBartłomiej Piotrowski2015-10-02 23:12:54 +0200
commitb99a0692f576d3191be9efbdb731226b1be868c9 (patch)
tree661af11adbc9e76d09bf6a71f17248e7d21160fc
downloadaur-b99a0692f576d3191be9efbdb731226b1be868c9.tar.gz
Initial commit (0.10.0-1)
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..984843c57575
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-aur
+ pkgdesc = Arch User Repository API interface for Python
+ pkgver = 0.10.0
+ pkgrel = 1
+ url = https://github.com/cdown/aur
+ arch = any
+ license = ISC
+ makedepends = python-setuptools
+ depends = python-requests
+ depends = python-inflection
+ source = https://pypi.python.org/packages/source/a/aur/aur-0.10.0.tar.gz
+ md5sums = fad8a5a1ff35f30c14a7b75a9258dafb
+
+pkgname = python-aur
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e48f804a2af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+
+pkgname=python-aur
+pkgver=0.10.0
+pkgrel=1
+pkgdesc='Arch User Repository API interface for Python'
+arch=('any')
+url='https://github.com/cdown/aur'
+license=('ISC')
+depends=('python-requests' 'python-inflection')
+makedepends=('python-setuptools')
+source=(https://pypi.python.org/packages/source/a/aur/aur-$pkgver.tar.gz)
+md5sums=('fad8a5a1ff35f30c14a7b75a9258dafb')
+
+package() {
+ cd aur-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}