summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2015-10-03 23:17:31 +0200
committerBartłomiej Piotrowski2015-10-03 23:17:31 +0200
commitc6e6538889e0f27f46c87873597652b068c9b1f2 (patch)
tree0e609eef4ef5376db0120307f3b4cd24266de835
parentb99a0692f576d3191be9efbdb731226b1be868c9 (diff)
downloadaur-c6e6538889e0f27f46c87873597652b068c9b1f2.tar.gz
Fix compatibility with AUR >= 4.1.0 (0.10-2)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--aur-0.10-no-popularity-in-v1.patch14
3 files changed, 27 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 984843c57575..6d69723d3369 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-aur
pkgdesc = Arch User Repository API interface for Python
pkgver = 0.10.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/cdown/aur
arch = any
license = ISC
@@ -9,7 +9,9 @@ pkgbase = python-aur
depends = python-requests
depends = python-inflection
source = https://pypi.python.org/packages/source/a/aur/aur-0.10.0.tar.gz
+ source = aur-0.10-no-popularity-in-v1.patch
md5sums = fad8a5a1ff35f30c14a7b75a9258dafb
+ md5sums = be8b45c7df9c3596817ff5178e122654
pkgname = python-aur
diff --git a/PKGBUILD b/PKGBUILD
index 4e48f804a2af..18957b523d82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,22 @@
pkgname=python-aur
pkgver=0.10.0
-pkgrel=1
+pkgrel=2
pkgdesc='Arch User Repository API interface for Python'
arch=('any')
url='https://github.com/cdown/aur'
license=('ISC')
depends=('python-requests' 'python-inflection')
makedepends=('python-setuptools')
-source=(https://pypi.python.org/packages/source/a/aur/aur-$pkgver.tar.gz)
-md5sums=('fad8a5a1ff35f30c14a7b75a9258dafb')
+source=(https://pypi.python.org/packages/source/a/aur/aur-$pkgver.tar.gz
+ aur-0.10-no-popularity-in-v1.patch)
+md5sums=('fad8a5a1ff35f30c14a7b75a9258dafb'
+ 'be8b45c7df9c3596817ff5178e122654')
+
+prepare() {
+ cd aur-$pkgver
+ patch -p1 -i ../aur-0.10-no-popularity-in-v1.patch
+}
package() {
cd aur-$pkgver
diff --git a/aur-0.10-no-popularity-in-v1.patch b/aur-0.10-no-popularity-in-v1.patch
new file mode 100644
index 000000000000..bd2c5a5f147e
--- /dev/null
+++ b/aur-0.10-no-popularity-in-v1.patch
@@ -0,0 +1,14 @@
+diff --git a/aur.py b/aur.py
+index 8bbac08..f607d38 100644
+--- a/aur.py
++++ b/aur.py
+@@ -168,8 +168,7 @@ _Package = namedtuple(
+ [
+ 'num_votes', 'description', 'url_path', 'last_modified', 'name',
+ 'out_of_date', 'id', 'first_submitted', 'maintainer', 'version',
+- 'license', 'url', 'package_base', 'package_base_id', 'popularity',
+- 'category_id',
++ 'license', 'url', 'package_base', 'package_base_id', 'category_id',
+ ],
+ )
+