summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2015-10-04 14:11:16 +0200
committerBartłomiej Piotrowski2015-10-04 14:11:16 +0200
commite8e200f604ea3fac1c0be4bb73e3855e94205abd (patch)
tree9623cc5897a861a36bebfb2671bfce8215520f8d
parentc6e6538889e0f27f46c87873597652b068c9b1f2 (diff)
downloadaur-e8e200f604ea3fac1c0be4bb73e3855e94205abd.tar.gz
upgpkg: python-aur 0.11
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
-rw-r--r--aur-0.10-no-popularity-in-v1.patch14
3 files changed, 8 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d69723d3369..430b159bcbc3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = python-aur
pkgdesc = Arch User Repository API interface for Python
- pkgver = 0.10.0
- pkgrel = 2
+ pkgver = 0.11.0
+ pkgrel = 1
url = https://github.com/cdown/aur
arch = any
license = ISC
makedepends = python-setuptools
depends = python-requests
depends = python-inflection
- source = https://pypi.python.org/packages/source/a/aur/aur-0.10.0.tar.gz
- source = aur-0.10-no-popularity-in-v1.patch
- md5sums = fad8a5a1ff35f30c14a7b75a9258dafb
- md5sums = be8b45c7df9c3596817ff5178e122654
+ source = https://pypi.python.org/packages/source/a/aur/aur-0.11.0.tar.gz
+ md5sums = 3519e86d744555781d5d98f561ff8665
pkgname = python-aur
diff --git a/PKGBUILD b/PKGBUILD
index 18957b523d82..ce01d02f28ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,16 @@
# Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
pkgname=python-aur
-pkgver=0.10.0
-pkgrel=2
+pkgver=0.11.0
+pkgrel=1
pkgdesc='Arch User Repository API interface for Python'
arch=('any')
url='https://github.com/cdown/aur'
license=('ISC')
depends=('python-requests' 'python-inflection')
makedepends=('python-setuptools')
-source=(https://pypi.python.org/packages/source/a/aur/aur-$pkgver.tar.gz
- aur-0.10-no-popularity-in-v1.patch)
-md5sums=('fad8a5a1ff35f30c14a7b75a9258dafb'
- 'be8b45c7df9c3596817ff5178e122654')
-
-prepare() {
- cd aur-$pkgver
- patch -p1 -i ../aur-0.10-no-popularity-in-v1.patch
-}
+source=(https://pypi.python.org/packages/source/a/aur/aur-$pkgver.tar.gz)
+md5sums=('3519e86d744555781d5d98f561ff8665')
package() {
cd aur-$pkgver
diff --git a/aur-0.10-no-popularity-in-v1.patch b/aur-0.10-no-popularity-in-v1.patch
deleted file mode 100644
index bd2c5a5f147e..000000000000
--- a/aur-0.10-no-popularity-in-v1.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/aur.py b/aur.py
-index 8bbac08..f607d38 100644
---- a/aur.py
-+++ b/aur.py
-@@ -168,8 +168,7 @@ _Package = namedtuple(
- [
- 'num_votes', 'description', 'url_path', 'last_modified', 'name',
- 'out_of_date', 'id', 'first_submitted', 'maintainer', 'version',
-- 'license', 'url', 'package_base', 'package_base_id', 'popularity',
-- 'category_id',
-+ 'license', 'url', 'package_base', 'package_base_id', 'category_id',
- ],
- )
-