summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBigfootACA2021-03-16 17:20:03 +0800
committerBigfootACA2021-03-16 17:20:03 +0800
commitb037c1408d6724e0398bdc36bcefa5786216cbe3 (patch)
tree6071580a518527eca157dbe04d6b43db53ec6fe7
downloadaur-b037c1408d6724e0398bdc36bcefa5786216cbe3.tar.gz
reset repo and upload
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD47
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec6906fe03e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = python-automaton
+ pkgdesc = Friendly state machines for python.
+ pkgver = 2.3.0
+ pkgrel = 1
+ url = https://opendev.org/openstack/automaton
+ arch = any
+ license = Apache
+ checkdepends = python-coverage
+ checkdepends = python-oslotest
+ checkdepends = python-stestr
+ checkdepends = python-testtools
+ checkdepends = python-reno
+ makedepends = python
+ makedepends = python-setuptools
+ depends = python
+ depends = python-pbr
+ depends = python-prettytable
+ source = https://pypi.io/packages/source/a/automaton/automaton-2.3.0.tar.gz
+ md5sums = 6d627a428a84ba03b0b4146dede1d45b
+ sha256sums = 3173a5fdbbb14ab4c6c53ea5c8f82c337fe4b3dc5a3dcd7d1804fd685868cf2e
+ sha512sums = 3e832f2cbaa147b57bcef024873454dbcb4e800d3873f4f6e533b137e49fee3cfe39efdacbfd700819c8c5f09e61f14d2862efc0daa78f79ad0e6f9c75161f8e
+
+pkgname = python-automaton
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fcaabd513b1a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,10 @@
+pkg
+src
+*.tar
+*.gz
+*.xz
+*.zst
+*.zip
+*.lz4
+*.lzo
+*.bz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b3a3be3eac96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: zhullyb <zhullyb@outlook.com>
+# Contributor: BigfootACA <bigfoot@classfun.cn>
+
+_pyname=automaton
+pkgname=python-$_pyname
+pkgver=2.3.0
+pkgrel=1
+pkgdesc="Friendly state machines for python."
+arch=(any)
+url="https://opendev.org/openstack/automaton"
+license=(Apache)
+depends=(
+ python
+ python-pbr
+ python-prettytable
+)
+checkdepends=(
+ python-coverage
+ python-oslotest
+ python-stestr
+ python-testtools
+ python-reno
+)
+makedepends=(
+ python
+ python-setuptools
+)
+source=(https://pypi.io/packages/source/${_pyname::1}/$_pyname/$_pyname-$pkgver.tar.gz)
+md5sums=('6d627a428a84ba03b0b4146dede1d45b')
+sha256sums=('3173a5fdbbb14ab4c6c53ea5c8f82c337fe4b3dc5a3dcd7d1804fd685868cf2e')
+sha512sums=('3e832f2cbaa147b57bcef024873454dbcb4e800d3873f4f6e533b137e49fee3cfe39efdacbfd700819c8c5f09e61f14d2862efc0daa78f79ad0e6f9c75161f8e')
+
+build(){
+ pushd $_pyname-$pkgver
+ python setup.py build
+}
+
+check(){
+ pushd $_pyname-$pkgver
+ stestr run
+}
+
+package(){
+ cd $_pyname-$pkgver
+ python setup.py install --root "$pkgdir" --optimize=1
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}