summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGamehunterKaan2022-08-15 17:59:48 +0300
committerGamehunterKaan2022-08-15 17:59:48 +0300
commitb5bd580aa35ff11150e2090bb1b4e8b49e5343a9 (patch)
treec1a5499efd57670af54fc42d617762553caa0592
downloadaur-b5bd580aa35ff11150e2090bb1b4e8b49e5343a9.tar.gz
Initial Push
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD20
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fb2e94aaffe0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-autopwn-suite
+ pkgdesc = AutoPWN Suite is a project for scanning vulnerabilities and exploiting systems automatically.
+ pkgver = 2.1.2
+ pkgrel = 1
+ url = https://auto.pwnspot.com
+ arch = any
+ license = EULA
+ makedepends = python-setuptools
+ depends = python
+ depends = python-requests
+ depends = python-rich
+ depends = python-nmap
+ depends = python-bs4
+ depends = python-distro
+ source = autopwn-suite-2.1.2.tar.gz::https://files.pythonhosted.org/packages/source/a/autopwn-suite/autopwn-suite-2.1.2.tar.gz
+ sha512sums = SKIP
+
+pkgname = python-autopwn-suite
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ab3e915aefb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Kaan Gültekin <kaangultekin01[at]gmail[dot]com>
+
+pkgname=python-autopwn-suite
+_pyname=autopwn-suite
+pkgver=2.1.2
+pkgrel=1
+pkgdesc="AutoPWN Suite is a project for scanning vulnerabilities and exploiting systems automatically."
+url="https://auto.pwnspot.com"
+arch=("any")
+depends=("python" "python-requests" "python-rich" "python-nmap" "python-bs4" "python-distro")
+makedepends=("python-setuptools")
+license=("EULA")
+source=("${_pyname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/a/${_pyname}/${_pyname}-${pkgver}.tar.gz")
+sha512sums=('SKIP')
+
+package() {
+ cd "${srcdir}/${_pyname}-${pkgver}"
+ python setup.py install -O1 --root="${pkgdir}"
+ install -Dm 644 README.md "${pkgdir}/usr/share/licenses/${pkgname}/README"
+}