summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Gerritse2022-01-07 14:56:06 +0100
committerJohn Gerritse2022-01-07 14:56:06 +0100
commit2dc29c582646616831fddf6d42d4c8fa35f227f8 (patch)
tree8ac146f5dc8eb19103507b83ce588f8683718a09
downloadaur-2dc29c582646616831fddf6d42d4c8fa35f227f8.tar.gz
New package, version 0.1.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ec747b1dc76
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-autosub3
+ pkgdesc = Auto-generates subtitles for any video or audio file, upgrades original autosub and adds support for windows.
+ pkgver = 0.4.7
+ pkgrel = 0
+ url = https://pypi.org/project/autosub3
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/a/autosub3/autosub3-0.4.7.tar.gz
+ sha256sums = 7fe8a351de227ec46b768b2b92ff0fa01cedbfe83a9fe1800fa183ff9356e3e0
+
+pkgname = python-autosub3
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4120e57e702f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: John Gerritse <tyrannis dot hawk at gmail dot com>
+pkgname=python-autosub3
+_name=${pkgname#python-}
+pkgver=0.1.0
+pkgrel=0
+pkgdesc='Auto-generates subtitles for any video or audio file, upgrades original autosub and adds support for windows.'
+arch=(any)
+url=https://pypi.org/project/autosub3
+license=(MIT)
+depends=(python)
+makedepends=(python-setuptools)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('a8e937384ed9b7b1f3f08e1ec77885cb75089afeeec47687ff627fd6a49cc254')
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+}