summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Fink2023-11-26 23:00:11 +0200
committerChristoph Fink2023-11-26 23:00:58 +0200
commitf603e3b3f46558f165252de48a6997bc89e78c93 (patch)
tree15da33836d63a5602e59992d58a730f62fa31623
parent398cef7367b4d9b60b5c4db4da91260d7bf82a99 (diff)
downloadaur-f603e3b3f46558f165252de48a6997bc89e78c93.tar.gz
upgpkg: python-av 11.0.0-4
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
-rw-r--r--deprecated-features-tests.patch32
3 files changed, 51 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b67f7edc434a..cf89de3f7c81 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-av
pkgdesc = Pythonic bindings for FFmpeg
pkgver = 11.0.0
- pkgrel = 3
+ pkgrel = 4
url = https://docs.mikeboers.com/pyav/
arch = x86_64
arch = i686
@@ -17,11 +17,13 @@ pkgbase = python-av
makedepends = python-setuptools
makedepends = python-wheel
makedepends = pkgconf
- depends = ffmpeg=2:6.0
+ depends = ffmpeg
depends = python
depends = python-numpy
depends = python-pillow
source = av-11.0.0.tar.gz::https://github.com/PyAV-Org/PyAV/archive/refs/tags/v11.0.0.tar.gz
+ source = deprecated-features-tests.patch
b2sums = 614c0338b207dbc88f9f7df9309a044df35707061af0986062f5ec7ad4dee4724eec1c37940623d1accc3ec1ded589a4a62087a3beaa6c2ef8be8524eeaab825
+ b2sums = c230efd4c01465841b18330e3ae64d8af81827b20610bd3e7296c0aa0d1aa131a08489ff964d4b273eb413a9ef34d19ebc507f228caf7743fb264e5c58445648
pkgname = python-av
diff --git a/PKGBUILD b/PKGBUILD
index a8ba95a7e752..fb960bc5f7ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,13 +7,13 @@ pkgdesc="Pythonic bindings for FFmpeg"
url="https://docs.mikeboers.com/pyav/"
pkgver=11.0.0
-pkgrel=3
+pkgrel=4
arch=("x86_64" "i686")
license=("BSD")
depends=(
- "ffmpeg=2:6.0"
+ "ffmpeg"
"python"
"python-numpy"
"python-pillow"
@@ -36,8 +36,19 @@ checkdepends=(
# source=( "https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
# upload failed upstream: https://github.com/PyAV-Org/PyAV/actions/runs/6747799842/job/18350415863
-source=( "$_name-$pkgver.tar.gz::https://github.com/${_upstream_name}-Org/${_upstream_name}/archive/refs/tags/v${pkgver}.tar.gz")
-b2sums=("614c0338b207dbc88f9f7df9309a044df35707061af0986062f5ec7ad4dee4724eec1c37940623d1accc3ec1ded589a4a62087a3beaa6c2ef8be8524eeaab825")
+source=(
+ "$_name-$pkgver.tar.gz::https://github.com/${_upstream_name}-Org/${_upstream_name}/archive/refs/tags/v${pkgver}.tar.gz"
+ "deprecated-features-tests.patch"
+)
+b2sums=(
+ "614c0338b207dbc88f9f7df9309a044df35707061af0986062f5ec7ad4dee4724eec1c37940623d1accc3ec1ded589a4a62087a3beaa6c2ef8be8524eeaab825"
+ "c230efd4c01465841b18330e3ae64d8af81827b20610bd3e7296c0aa0d1aa131a08489ff964d4b273eb413a9ef34d19ebc507f228caf7743fb264e5c58445648"
+)
+
+prepare() {
+ cd "${srcdir}"/${_upstream_name}-${pkgver}
+ patch --forward --strip=1 --input="${srcdir}/deprecated-features-tests.patch"
+}
build() {
cd "${srcdir}"/${_upstream_name}-${pkgver}
diff --git a/deprecated-features-tests.patch b/deprecated-features-tests.patch
new file mode 100644
index 000000000000..f1f19716df22
--- /dev/null
+++ b/deprecated-features-tests.patch
@@ -0,0 +1,32 @@
+diff --unified --recursive --text a/tests/test_file_probing.py b/tests/test_file_probing.py
+--- a/tests/test_file_probing.py 2023-11-03 18:23:00.000000000 +0200
++++ b/tests/test_file_probing.py 2023-11-26 22:59:22.855618027 +0200
+@@ -320,20 +320,6 @@
+ self.assertIn(stream.coded_width, (720, 0))
+ self.assertIn(stream.coded_height, (576, 0))
+
+- # Deprecated properties.
+- with warnings.catch_warnings(record=True) as captured:
+- self.assertIsNone(stream.framerate)
+- self.assertEqual(
+- captured[0].message.args[0],
+- "VideoStream.framerate is deprecated as it is not always set; please use VideoStream.average_rate.",
+- )
+- with warnings.catch_warnings(record=True) as captured:
+- self.assertIsNone(stream.rate)
+- self.assertEqual(
+- captured[0].message.args[0],
+- "VideoStream.rate is deprecated as it is not always set; please use VideoStream.average_rate.",
+- )
+-
+
+ class TestVideoProbeCorrupt(TestCase):
+ def setUp(self):
+@@ -362,7 +348,6 @@
+ self.assertTrue(str(stream).startswith("<av.VideoStream #0 h264, None 0x0 at "))
+
+ # actual stream properties
+- self.assertEqual(stream.average_rate, None)
+ self.assertEqual(stream.duration, None)
+ self.assertEqual(stream.frames, 0)
+ self.assertEqual(stream.id, 0)