summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo J. S. Bellini2018-11-19 20:33:52 -0200
committerDanilo J. S. Bellini2018-11-19 20:33:52 -0200
commitd2afc6496c3f4565221d88a875f2f2ab78b6d324 (patch)
tree224545b93b0a0aaf1bd5cc0e341d189a7b960063
parent7f708855f2aa91ba126898bcacccdcf72e3705c0 (diff)
downloadaur-d2afc6496c3f4565221d88a875f2f2ab78b6d324.tar.gz
v4.4.0-2: Apply patch for prompt_toolkit v2
Apply a patch to make axelrod work with prompt_toolkit v2, which is the current version in the community repo (v2.0.7-1)
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD17
2 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b101256c5394..d49e8df5fadc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-axelrod
pkgdesc = Research tool for the Iterated Prisoner's Dilemma
pkgver = 4.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Axelrod-Python/Axelrod
arch = any
license = MIT
@@ -11,11 +11,14 @@ pkgbase = python-axelrod
depends = python-numpy
depends = python-pandas
depends = python-prompt_toolkit
+ depends = python-pygments
depends = python-scipy
depends = python-tqdm
options = !emptydirs
source = https://github.com/Axelrod-Python/Axelrod/archive/v4.4.0.tar.gz
+ source = https://github.com/Axelrod-Python/Axelrod/commit/8dba4c0.patch
sha256sums = 1f8f8386ab292877e9c063aa371e0d5709a969cce9cba828ee95567be1858c7e
+ sha256sums = 4d9d11b7d8ccd2074295b92b4961fd76b25e3948cb8e9836acd0123a5b6166f2
pkgname = python-axelrod
diff --git a/PKGBUILD b/PKGBUILD
index cc49eb3ec063..f1e41f45260b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Danilo J. S. Bellini <danilo dot bellini at gmail dot com>
pkgname=('python-axelrod')
pkgver=4.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="Research tool for the Iterated Prisoner's Dilemma"
arch=('any')
url='https://github.com/Axelrod-Python/Axelrod'
@@ -9,15 +9,22 @@ license=('MIT')
makedepends=('python-setuptools')
depends=('python-dask'
'python-matplotlib' 'python-numpy' 'python-pandas'
- 'python-prompt_toolkit' 'python-scipy'
+ 'python-prompt_toolkit' 'python-pygments' 'python-scipy'
'python-tqdm')
options=(!emptydirs)
-sha256sums=('1f8f8386ab292877e9c063aa371e0d5709a969cce9cba828ee95567be1858c7e')
-source=("$url/archive/v$pkgver.tar.gz")
+sha256sums=('1f8f8386ab292877e9c063aa371e0d5709a969cce9cba828ee95567be1858c7e'
+ '4d9d11b7d8ccd2074295b92b4961fd76b25e3948cb8e9836acd0123a5b6166f2')
+source=("$url/archive/v$pkgver.tar.gz"
+ "$url/commit/8dba4c0.patch")
prepare() {
+ cd "$srcdir/Axelrod-$pkgver"
+
+ # Reverse the 8dba4c0 commit as we have prompt_toolkit v2, not v1
+ patch -Rp1 < "$srcdir/8dba4c0.patch"
+
# Avoid installing optional/unrequired dependencies
- echo > "$srcdir/Axelrod-$pkgver/requirements.txt"
+ echo > "requirements.txt"
}
package() {