summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKelsey Maes2019-01-01 10:57:18 -0800
committerKelsey Maes2019-01-01 10:57:18 -0800
commit621110f3ff1d79248b7814b97317819dd0da2ade (patch)
treed2e38d4932bf78716e8de10ebd4775c523647086
parent71ef96a2899f73595b52bd40e9997d6cfec0d7e9 (diff)
downloadaur-621110f3ff1d79248b7814b97317819dd0da2ade.tar.gz
Update to 2.0.52
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
-rw-r--r--wheel.patch40
3 files changed, 54 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c330d3ae5f5..8f28d2f8c825 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-azure-cli
pkgdesc = Microsoft Azure Command-Line Tools
- pkgver = 2.0.50
+ pkgver = 2.0.52
pkgrel = 1
url = https://github.com/Azure/azure-cli
arch = any
@@ -20,9 +20,12 @@ pkgbase = python-azure-cli
depends = python-sshtunnel
depends = python-tabulate
depends = python-vsts-cd-manager
+ depends = python-wheel
depends = python-yaml
- source = https://github.com/Azure/azure-cli/archive/azure-cli-2.0.50.tar.gz
- sha256sums = decbf866e5a4e22914ed177553b89c0b017bf459eacb16e703766e0eae7efa69
+ source = https://github.com/Azure/azure-cli/archive/azure-cli-2.0.52.tar.gz
+ source = wheel.patch
+ sha256sums = 4fe43b7eff3212aace6906505e1cec7cb06b7626da757d1890c6e1c5e82218bd
+ sha256sums = 33450e8feaa7bb20a5e64ef628c88ddf998d88c302b6f85458c319f68c167dfd
pkgname = python-azure-cli
diff --git a/PKGBUILD b/PKGBUILD
index 1fd0e96b1a4b..8eb1237ba741 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_name=azure-cli
pkgname=python-$_name
-pkgver=2.0.50
+pkgver=2.0.52
pkgrel=1
pkgdesc="Microsoft Azure Command-Line Tools"
arch=('any')
@@ -11,14 +11,18 @@ license=('MIT')
depends=('python-applicationinsights' 'python-argcomplete' 'python-azure'
'python-colorama' 'python-humanfriendly' 'python-jmespath' 'python-knack'
'python-pyopenssl' 'python-pytz' 'python-scp' 'python-sshtunnel'
- 'python-tabulate' 'python-vsts-cd-manager' 'python-yaml')
+ 'python-tabulate' 'python-vsts-cd-manager' 'python-wheel' 'python-yaml')
makedepends=('git' 'python-setuptools')
-source=("https://github.com/Azure/azure-cli/archive/azure-cli-${pkgver}.tar.gz")
-sha256sums=('decbf866e5a4e22914ed177553b89c0b017bf459eacb16e703766e0eae7efa69')
+source=("https://github.com/Azure/azure-cli/archive/azure-cli-${pkgver}.tar.gz"
+ "wheel.patch")
+sha256sums=('4fe43b7eff3212aace6906505e1cec7cb06b7626da757d1890c6e1c5e82218bd'
+ '33450e8feaa7bb20a5e64ef628c88ddf998d88c302b6f85458c319f68c167dfd')
build() {
cd "$_name-$_name-$pkgver/src"
+ patch -p2 < ../../wheel.patch
+
for d in azure-cli \
azure-cli-core \
azure-cli-nspkg \
diff --git a/wheel.patch b/wheel.patch
new file mode 100644
index 000000000000..5c53f460f8e7
--- /dev/null
+++ b/wheel.patch
@@ -0,0 +1,40 @@
+diff -crB azure-cli-azure-cli-2.0.52/src/azure-cli-core/azure/cli/core/extension/operations.py azure-cli-azure-cli-2.0.52_fixed/src/azure-cli-core/azure/cli/core/extension/operations.py
+*** azure-cli-azure-cli-2.0.52/src/azure-cli-core/azure/cli/core/extension/operations.py 2018-11-29 13:32:10.000000000 -0800
+--- azure-cli-azure-cli-2.0.52_fixed/src/azure-cli-core/azure/cli/core/extension/operations.py 2019-01-01 10:40:31.594122272 -0800
+***************
+*** 14,20 ****
+ from collections import OrderedDict
+
+ import requests
+! from wheel.install import WHEEL_INFO_RE
+ from pkg_resources import parse_version
+
+ from knack.log import get_logger
+--- 14,20 ----
+ from collections import OrderedDict
+
+ import requests
+! from wheel.wheelfile import WHEEL_INFO_RE
+ from pkg_resources import parse_version
+
+ from knack.log import get_logger
+diff -crB azure-cli-azure-cli-2.0.52/src/azure-cli-core/azure/cli/core/extension/_resolve.py azure-cli-azure-cli-2.0.52_fixed/src/azure-cli-core/azure/cli/core/extension/_resolve.py
+*** azure-cli-azure-cli-2.0.52/src/azure-cli-core/azure/cli/core/extension/_resolve.py 2018-11-29 13:32:10.000000000 -0800
+--- azure-cli-azure-cli-2.0.52_fixed/src/azure-cli-core/azure/cli/core/extension/_resolve.py 2019-01-01 10:40:46.814055369 -0800
+***************
+*** 2,8 ****
+ # Copyright (c) Microsoft Corporation. All rights reserved.
+ # Licensed under the MIT License. See License.txt in the project root for license information.
+ # --------------------------------------------------------------------------------------------
+! from wheel.install import WHEEL_INFO_RE
+ from pkg_resources import parse_version
+
+ from knack.log import get_logger
+--- 2,8 ----
+ # Copyright (c) Microsoft Corporation. All rights reserved.
+ # Licensed under the MIT License. See License.txt in the project root for license information.
+ # --------------------------------------------------------------------------------------------
+! from wheel.wheelfile import WHEEL_INFO_RE
+ from pkg_resources import parse_version
+
+ from knack.log import get_logger