summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKelsey Maes2017-03-19 12:11:14 -0700
committerKelsey Maes2017-03-19 12:11:14 -0700
commitae122b28de69070ac71fab5f863c367ec59cb010 (patch)
tree268571e651f255839940d065053f1e28f440e469
downloadaur-ae122b28de69070ac71fab5f863c367ec59cb010.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df38ff8fff99
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-azure-cli
+ pkgdesc = Microsoft Azure Command-Line Tools
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = https://github.com/Azure/azure-cli
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-azure-cli-core
+ source = https://files.pythonhosted.org/packages/source/a/azure-cli/azure-cli-2.0.1.tar.gz
+ md5sums = f1eb3c2a9f6ac008d2741c6e37b066c4
+
+pkgname = python-azure-cli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..797c7ddc7ab6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Kelsey Maes <kelseymaes at outlook dot com>
+
+_name=azure-cli
+pkgname=python-$_name
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="Microsoft Azure Command-Line Tools"
+arch=('any')
+url="https://github.com/Azure/azure-cli"
+license=('MIT')
+depends=('python-azure-cli-core')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+md5sums=('f1eb3c2a9f6ac008d2741c6e37b066c4')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}