summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKelsey Maes2017-03-19 20:52:36 -0700
committerKelsey Maes2017-03-19 20:52:36 -0700
commitdf946ecd377f04db369e9ae3326308dfabe3761b (patch)
tree3827969e2639a1ce1ffd28d089fcb63bcdd24a93
downloadaur-df946ecd377f04db369e9ae3326308dfabe3761b.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0bfb9644c40
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-azure-cli-batch
+ pkgdesc = Microsoft Azure Command-Line Tools Batch Command Module
+ pkgver = 0.1.1b5
+ pkgrel = 1
+ url = https://github.com/Azure/azure-cli
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-azure
+ depends = python-azure-cli-core
+ source = https://files.pythonhosted.org/packages/source/a/azure-cli-batch/azure-cli-batch-0.1.1b5.tar.gz
+ md5sums = a839278f4a365b49adaa5530f25260f2
+
+pkgname = python-azure-cli-batch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6fd9940bf03
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Kelsey Maes <kelseymaes at outlook dot com>
+
+_name=azure-cli-batch
+pkgname=python-$_name
+pkgver=0.1.1b5
+pkgrel=1
+pkgdesc="Microsoft Azure Command-Line Tools Batch Command Module"
+arch=('any')
+url="https://github.com/Azure/azure-cli"
+license=('MIT')
+depends=('python-azure' 'python-azure-cli-core')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+md5sums=('a839278f4a365b49adaa5530f25260f2')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}