summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKelsey Maes2017-05-01 22:42:44 -0700
committerKelsey Maes2017-05-01 22:42:44 -0700
commit8c46a3531bc21f28753f7ae8352826aeecb5dfce (patch)
tree0c6de9acb0586228ad152da124162d3ca9b5823e
parentb3bbefabaded4599efddf021c8a29b7ae9d90398 (diff)
downloadaur-8c46a3531bc21f28753f7ae8352826aeecb5dfce.tar.gz
2.0.4 update
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c26dad7374f..0a065ca25036 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = python-azure-cli-component
pkgdesc = Microsoft Azure Command-Line Tools Component Command Module
- pkgver = 2.0.0
+ pkgver = 2.0.2
pkgrel = 1
url = https://github.com/Azure/azure-cli
arch = any
license = MIT
makedepends = python-setuptools
+ depends = python-azure-cli-command-modules-nspkg
depends = python-azure-cli-core
- source = https://files.pythonhosted.org/packages/source/a/azure-cli-component/azure-cli-component-2.0.0.tar.gz
- md5sums = 70f11f2d846f4f9e0de4b8a884a50c88
+ source = https://files.pythonhosted.org/packages/source/a/azure-cli-component/azure-cli-component-2.0.2.tar.gz
+ md5sums = ffe559c74d53a52415369e93d9425fad
pkgname = python-azure-cli-component
diff --git a/PKGBUILD b/PKGBUILD
index 857b95e3f1b8..2630ca835b37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
_name=azure-cli-component
pkgname=python-$_name
-pkgver=2.0.0
+pkgver=2.0.2
pkgrel=1
pkgdesc="Microsoft Azure Command-Line Tools Component Command Module"
arch=('any')
url="https://github.com/Azure/azure-cli"
license=('MIT')
-depends=('python-azure-cli-core')
+depends=('python-azure-cli-command-modules-nspkg' 'python-azure-cli-core')
makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-md5sums=('70f11f2d846f4f9e0de4b8a884a50c88')
+md5sums=('ffe559c74d53a52415369e93d9425fad')
build() {
cd "$_name-$pkgver"
@@ -21,4 +21,13 @@ build() {
package() {
cd "$_name-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
+
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/__init__.py
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/__pycache__/__init__.*
+
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/__init__.py
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/__pycache__/__init__.*
+
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/command_modules/__init__.py
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/command_modules/__pycache__/__init__.*
}