summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKelsey Maes2017-03-19 20:58:39 -0700
committerKelsey Maes2017-03-19 20:58:39 -0700
commitb3bbefabaded4599efddf021c8a29b7ae9d90398 (patch)
tree954146676970c222980b43357eea997ab98abaf2
downloadaur-b3bbefabaded4599efddf021c8a29b7ae9d90398.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c26dad7374f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-azure-cli-component
+ pkgdesc = Microsoft Azure Command-Line Tools Component Command Module
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/Azure/azure-cli
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-azure-cli-core
+ source = https://files.pythonhosted.org/packages/source/a/azure-cli-component/azure-cli-component-2.0.0.tar.gz
+ md5sums = 70f11f2d846f4f9e0de4b8a884a50c88
+
+pkgname = python-azure-cli-component
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..857b95e3f1b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Kelsey Maes <kelseymaes at outlook dot com>
+
+_name=azure-cli-component
+pkgname=python-$_name
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Microsoft Azure Command-Line Tools Component Command Module"
+arch=('any')
+url="https://github.com/Azure/azure-cli"
+license=('MIT')
+depends=('python-azure-cli-core')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+md5sums=('70f11f2d846f4f9e0de4b8a884a50c88')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}