summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKelsey Maes2017-05-01 22:43:14 -0700
committerKelsey Maes2017-05-01 22:43:14 -0700
commit78e5e05e9de61b5b204477c439f7ab6197ccd495 (patch)
tree7d0793ed9ee0d7d1e6befc150bc6510a68eb89b6
parent89f47732d45ffe8077204bd70ddf94b05276683a (diff)
downloadaur-78e5e05e9de61b5b204477c439f7ab6197ccd495.tar.gz
2.0.4 update
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5709e44fb66f..a2969fbc8636 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = python-azure-cli-configure
pkgdesc = Microsoft Azure Command-Line Tools Configure Command Module
- pkgver = 2.0.1
+ pkgver = 2.0.4
pkgrel = 1
url = https://github.com/Azure/azure-cli
arch = any
license = MIT
makedepends = python-setuptools
+ depends = python-azure-cli-command-modules-nspkg
depends = python-azure-cli-core
- source = https://files.pythonhosted.org/packages/source/a/azure-cli-configure/azure-cli-configure-2.0.1.tar.gz
- md5sums = e444323eb0b1f1d8b49646a4c6a6e777
+ source = https://files.pythonhosted.org/packages/source/a/azure-cli-configure/azure-cli-configure-2.0.4.tar.gz
+ md5sums = ed09835e0e7fdb3928370744cdc46c3f
pkgname = python-azure-cli-configure
diff --git a/PKGBUILD b/PKGBUILD
index 48943b5b94df..ba02ae9271c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
_name=azure-cli-configure
pkgname=python-$_name
-pkgver=2.0.1
+pkgver=2.0.4
pkgrel=1
pkgdesc="Microsoft Azure Command-Line Tools Configure Command Module"
arch=('any')
url="https://github.com/Azure/azure-cli"
license=('MIT')
-depends=('python-azure-cli-core')
+depends=('python-azure-cli-command-modules-nspkg' 'python-azure-cli-core')
makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-md5sums=('e444323eb0b1f1d8b49646a4c6a6e777')
+md5sums=('ed09835e0e7fdb3928370744cdc46c3f')
build() {
cd "$_name-$pkgver"
@@ -21,4 +21,13 @@ build() {
package() {
cd "$_name-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
+
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/__init__.py
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/__pycache__/__init__.*
+
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/__init__.py
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/__pycache__/__init__.*
+
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/command_modules/__init__.py
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/command_modules/__pycache__/__init__.*
}