summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKelsey Maes2017-03-19 20:58:58 -0700
committerKelsey Maes2017-03-19 20:58:58 -0700
commit89f47732d45ffe8077204bd70ddf94b05276683a (patch)
treee1fe66b399130030b52e821cad1d124ec4622754
downloadaur-89f47732d45ffe8077204bd70ddf94b05276683a.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5709e44fb66f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-azure-cli-configure
+ pkgdesc = Microsoft Azure Command-Line Tools Configure Command Module
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = https://github.com/Azure/azure-cli
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-azure-cli-core
+ source = https://files.pythonhosted.org/packages/source/a/azure-cli-configure/azure-cli-configure-2.0.1.tar.gz
+ md5sums = e444323eb0b1f1d8b49646a4c6a6e777
+
+pkgname = python-azure-cli-configure
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48943b5b94df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Kelsey Maes <kelseymaes at outlook dot com>
+
+_name=azure-cli-configure
+pkgname=python-$_name
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="Microsoft Azure Command-Line Tools Configure Command Module"
+arch=('any')
+url="https://github.com/Azure/azure-cli"
+license=('MIT')
+depends=('python-azure-cli-core')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+md5sums=('e444323eb0b1f1d8b49646a4c6a6e777')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}