summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKelsey Maes2017-03-19 21:01:20 -0700
committerKelsey Maes2017-03-19 21:01:20 -0700
commit03d918648cfeaa68303c3008d7e2bd8833ec13b8 (patch)
tree713fd1b8f31827749673a4b4c2bd5f1e5c53d975
downloadaur-03d918648cfeaa68303c3008d7e2bd8833ec13b8.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05247000c134
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-azure-cli-redis
+ pkgdesc = Microsoft Azure Command-Line Tools Redis Command Module
+ pkgver = 0.1.1b3
+ pkgrel = 1
+ url = https://github.com/Azure/azure-cli
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-azure
+ depends = python-azure-cli-core
+ source = https://files.pythonhosted.org/packages/source/a/azure-cli-redis/azure-cli-redis-0.1.1b3.tar.gz
+ md5sums = 2b621d453059d70c8d2c5f0fb5ff1357
+
+pkgname = python-azure-cli-redis
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2d73ec8838a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Kelsey Maes <kelseymaes at outlook dot com>
+
+_name=azure-cli-redis
+pkgname=python-$_name
+pkgver=0.1.1b3
+pkgrel=1
+pkgdesc="Microsoft Azure Command-Line Tools Redis Command Module"
+arch=('any')
+url="https://github.com/Azure/azure-cli"
+license=('MIT')
+depends=('python-azure' 'python-azure-cli-core')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+md5sums=('2b621d453059d70c8d2c5f0fb5ff1357')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}