summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKelsey Maes2017-03-19 21:01:52 -0700
committerKelsey Maes2017-03-19 21:01:52 -0700
commit704ccd632d513e77a24f0207d57d3b0df9777778 (patch)
tree005c93249579cc3663abfb5385a0701842a51b37
downloadaur-704ccd632d513e77a24f0207d57d3b0df9777778.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2c4b4972a874
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-azure-cli-role
+ pkgdesc = Microsoft Azure Command-Line Tools Role Command Module
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/Azure/azure-cli
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-azure
+ depends = python-azure-cli-core
+ source = https://files.pythonhosted.org/packages/source/a/azure-cli-role/azure-cli-role-2.0.0.tar.gz
+ md5sums = 9710304492cb739c1f0c65befc4689f4
+
+pkgname = python-azure-cli-role
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6382b01329cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Kelsey Maes <kelseymaes at outlook dot com>
+
+_name=azure-cli-role
+pkgname=python-$_name
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Microsoft Azure Command-Line Tools Role Command Module"
+arch=('any')
+url="https://github.com/Azure/azure-cli"
+license=('MIT')
+depends=('python-azure' 'python-azure-cli-core')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+md5sums=('9710304492cb739c1f0c65befc4689f4')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}