summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKelsey Maes2017-05-01 22:49:13 -0700
committerKelsey Maes2017-05-01 22:49:13 -0700
commit7432020ac51721b5e6e3c0f757be1fe3c1917929 (patch)
treef9189e17295d41c17471829610171f595f77a65f
parent704ccd632d513e77a24f0207d57d3b0df9777778 (diff)
downloadaur-7432020ac51721b5e6e3c0f757be1fe3c1917929.tar.gz
2.0.4 update
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c4b4972a874..3d24e29b99e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = python-azure-cli-role
pkgdesc = Microsoft Azure Command-Line Tools Role Command Module
- pkgver = 2.0.0
+ pkgver = 2.0.3
pkgrel = 1
url = https://github.com/Azure/azure-cli
arch = any
license = MIT
makedepends = python-setuptools
depends = python-azure
+ depends = python-azure-cli-command-modules-nspkg
depends = python-azure-cli-core
- source = https://files.pythonhosted.org/packages/source/a/azure-cli-role/azure-cli-role-2.0.0.tar.gz
- md5sums = 9710304492cb739c1f0c65befc4689f4
+ source = https://files.pythonhosted.org/packages/source/a/azure-cli-role/azure-cli-role-2.0.3.tar.gz
+ md5sums = 4419ea2af863d4a27d1d42ee2717cdd2
pkgname = python-azure-cli-role
diff --git a/PKGBUILD b/PKGBUILD
index 6382b01329cf..524438d1829f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
_name=azure-cli-role
pkgname=python-$_name
-pkgver=2.0.0
+pkgver=2.0.3
pkgrel=1
pkgdesc="Microsoft Azure Command-Line Tools Role Command Module"
arch=('any')
url="https://github.com/Azure/azure-cli"
license=('MIT')
-depends=('python-azure' 'python-azure-cli-core')
+depends=('python-azure' 'python-azure-cli-command-modules-nspkg' 'python-azure-cli-core')
makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-md5sums=('9710304492cb739c1f0c65befc4689f4')
+md5sums=('4419ea2af863d4a27d1d42ee2717cdd2')
build() {
cd "$_name-$pkgver"
@@ -21,4 +21,13 @@ build() {
package() {
cd "$_name-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
+
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/__init__.py
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/__pycache__/__init__.*
+
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/__init__.py
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/__pycache__/__init__.*
+
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/command_modules/__init__.py
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/command_modules/__pycache__/__init__.*
}