summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKelsey Maes2017-05-01 22:49:38 -0700
committerKelsey Maes2017-05-01 22:49:38 -0700
commit588bc17cbb92ed1cadeb72a4ec1ccb67e4ab6502 (patch)
tree3958b50a3e0aa0f1604a432f85393040b7adf59d
parentd52481348d207b9e30fa5c237486cd2bddc2fde9 (diff)
downloadaur-588bc17cbb92ed1cadeb72a4ec1ccb67e4ab6502.tar.gz
2.0.4 update
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a227e1ab2d8a..129374589a72 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = python-azure-cli-sql
pkgdesc = Microsoft Azure Command-Line Tools SQL Command Module
- pkgver = 0.1.1b6
+ pkgver = 2.0.2
pkgrel = 1
url = https://github.com/Azure/azure-cli
arch = any
license = MIT
makedepends = python-setuptools
depends = python-azure
+ depends = python-azure-cli-command-modules-nspkg
depends = python-azure-cli-core
- source = https://files.pythonhosted.org/packages/source/a/azure-cli-sql/azure-cli-sql-0.1.1b6.tar.gz
- md5sums = b0a40ae977d9b35b5c4ce4a8853310fc
+ source = https://files.pythonhosted.org/packages/source/a/azure-cli-sql/azure-cli-sql-2.0.2.tar.gz
+ md5sums = 915f3ffa68ee3f6c290316bd563a791b
pkgname = python-azure-cli-sql
diff --git a/PKGBUILD b/PKGBUILD
index d69712119cfa..e50172814caf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
_name=azure-cli-sql
pkgname=python-$_name
-pkgver=0.1.1b6
+pkgver=2.0.2
pkgrel=1
pkgdesc="Microsoft Azure Command-Line Tools SQL Command Module"
arch=('any')
url="https://github.com/Azure/azure-cli"
license=('MIT')
-depends=('python-azure' 'python-azure-cli-core')
+depends=('python-azure' 'python-azure-cli-command-modules-nspkg' 'python-azure-cli-core')
makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-md5sums=('b0a40ae977d9b35b5c4ce4a8853310fc')
+md5sums=('915f3ffa68ee3f6c290316bd563a791b')
build() {
cd "$_name-$pkgver"
@@ -21,4 +21,13 @@ build() {
package() {
cd "$_name-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
+
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/__init__.py
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/__pycache__/__init__.*
+
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/__init__.py
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/__pycache__/__init__.*
+
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/command_modules/__init__.py
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/command_modules/__pycache__/__init__.*
}