summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGerard Ribugent2024-01-10 08:34:45 +0100
committerGerard Ribugent2024-01-10 08:34:45 +0100
commitd79ad4eab55bae5ac4fc36f41397213c7b077f30 (patch)
tree5c0ba1eae700a8ec675459184533bdc6eed305d6
parent07ffda35109dd79943caf36a7d9c8a4cdbe283b2 (diff)
downloadaur-d79ad4eab55bae5ac4fc36f41397213c7b077f30.tar.gz
Bump version
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4f613ac1a8b..7fa38e80aa03 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = python-azure-core
pkgdesc = Microsoft Azure Core Library for Python
- pkgver = 1.29.4
+ pkgver = 1.29.6
pkgrel = 1
url = https://github.com/Azure/azure-sdk-for-python/tree/main/sdk/core/azure-core
arch = any
license = MIT
makedepends = python-installer
makedepends = python-setuptools
- depends = python-aiohttp>=3.0.0
+ depends = python-anyio>=3.0.0
+ depends = python-anyio<5.0.0
depends = python-requests>=2.18.4
depends = python-six>=1.11.0
depends = python-typing_extensions>=4.6.0
optdepends = python-aiohttp>=3.0
- source = https://files.pythonhosted.org/packages/py3/a/azure_core/azure_core-1.29.4-py3-none-any.whl
- sha256sums = b03261bcba22c0b9290faf9999cedd23e849ed2577feee90515694cea6bc74bf
+ source = https://files.pythonhosted.org/packages/py3/a/azure_core/azure_core-1.29.6-py3-none-any.whl
+ sha256sums = 604a005bce6a49ba661bb7b2be84a9b169047e52fcfcd0a4e4770affab4178f7
pkgname = python-azure-core
diff --git a/PKGBUILD b/PKGBUILD
index b09f646b453d..977cb59d3ee7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Gerard Ribugent <ribugent <at> gmail <dot> com>
pkgname='python-azure-core'
_name='azure_core'
-pkgver='1.29.4'
+pkgver='1.29.6'
pkgrel=1
pkgdesc="Microsoft Azure Core Library for Python"
url="https://github.com/Azure/azure-sdk-for-python/tree/main/sdk/core/azure-core"
depends=(
- 'python-aiohttp>=3.0.0'
+ 'python-anyio>=3.0.0' 'python-anyio<5.0.0'
'python-requests>=2.18.4'
'python-six>=1.11.0'
'python-typing_extensions>=4.6.0'
@@ -15,11 +15,15 @@ optdepends=(
'python-aiohttp>=3.0'
)
+makedepends=(
+ 'python-installer'
+)
+
makedepends=('python-installer' 'python-setuptools')
license=('MIT')
arch=('any')
source=("https://files.pythonhosted.org/packages/py3/${_name::1}/$_name/${_name//-/_}-$pkgver-py3-none-any.whl")
-sha256sums=('b03261bcba22c0b9290faf9999cedd23e849ed2577feee90515694cea6bc74bf')
+sha256sums=('604a005bce6a49ba661bb7b2be84a9b169047e52fcfcd0a4e4770affab4178f7')
package() {
python -m installer --destdir="$pkgdir" ${_name}-${pkgver}-py3-none-any.whl