summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKelsey Maes2017-03-19 20:40:18 -0700
committerKelsey Maes2017-03-19 20:40:18 -0700
commit1edf8680404aa598e976fbc73a69553026356891 (patch)
tree0ded1d7ed7bd3a273a46093567ea8e5ccd400752
downloadaur-1edf8680404aa598e976fbc73a69553026356891.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a4a91dd834fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-azure-git
+ pkgdesc = Microsoft Azure SDK for Python
+ pkgver = latest
+ pkgrel = 1
+ url = https://github.com/Azure/azure-sdk-for-python
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-azure-storage
+ depends = python-msrestazure
+ provides = python-azure
+ conflicts = python-azure
+ source = git+https://github.com/Azure/azure-sdk-for-python.git
+ md5sums = SKIP
+
+pkgname = python-azure-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2674e4636948
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Kelsey Maes <kelseymaes at outlook dot com>
+
+pkgname=python-azure-git
+pkgver=latest
+pkgrel=1
+pkgdesc="Microsoft Azure SDK for Python"
+arch=('any')
+url="https://github.com/Azure/azure-sdk-for-python"
+license=('MIT')
+depends=('python-azure-storage' 'python-msrestazure')
+makedepends=('python-setuptools')
+provides=('python-azure')
+conflicts=('python-azure')
+source=("git+https://github.com/Azure/azure-sdk-for-python.git")
+md5sums=('SKIP')
+
+build() {
+ cd azure-sdk-for-python
+ python setup.py build
+}
+
+package() {
+ cd azure-sdk-for-python
+ python setup.py install --root="$pkgdir" --optimize=1
+}