summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Manna2021-02-14 08:13:25 -0800
committerKyle Manna2021-02-14 10:08:53 -0800
commit6bcdd5dcb5827c6b24a20e715b7cd6c9894fc6b5 (patch)
treed8d69b673f5967533d2098baea4bd0d42a10dc07
parent354e16dd301a59d09acab0d0e69a3bbc8706daa3 (diff)
downloadaur-6bcdd5dcb582.tar.gz
revert: python-b2sdk v1.2.0-1
* Revert until backblaze-b2 release pkg has support for this: https://github.com/Backblaze/B2_Command_Line_Tool/blob/v2.1.0/requirements.txt
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a3531e376b1..fe193320263d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-b2sdk
pkgdesc = Python library to access B2 cloud storage.
- pkgver = 1.3.0
+ pkgver = 1.2.0
pkgrel = 1
url = https://github.com/Backblaze/b2-sdk-python
arch = any
@@ -11,8 +11,8 @@ pkgbase = python-b2sdk
depends = python-requests>=2.9.1
depends = python-setuptools
depends = python-tqdm>=4.5.0
- source = https://github.com/Backblaze/b2-sdk-python/archive/v1.3.0.tar.gz
- sha256sums = e01262da7b12f352b34f1ed1634315f7b9c4ad196a0a6fe51356e8ea452d9851
+ source = https://github.com/Backblaze/b2-sdk-python/archive/v1.2.0.tar.gz
+ sha256sums = 80d2daeaee38178a4d76922da2e69d7ad1f0d90fccea90d724a38909abb69b27
pkgname = python-b2sdk
diff --git a/PKGBUILD b/PKGBUILD
index f083b9eadb01..f455aa881449 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,10 @@
# Maintainer: Kyle Manna <kyle[at]kylemanna[d0t]com>
pkgname=python-b2sdk
-_pkgname=b2sdk
-pkgver=1.3.0
+_pkgname=b2-sdk-python
+#_pkgname=b2sdk
+#pkgver=1.3.0
+pkgver=1.2.0
pkgrel=1
pkgdesc='Python library to access B2 cloud storage.'
arch=(any)
@@ -16,8 +18,10 @@ depends=('python'
'python-tqdm>=4.5.0'
)
-source=("https://files.pythonhosted.org/packages/source/b/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('af53e2449414b772a0bd6fad311d98a171c3693f77ebca933499946e786715ae')
+#source=("https://files.pythonhosted.org/packages/source/b/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+#sha256sums=('af53e2449414b772a0bd6fad311d98a171c3693f77ebca933499946e786715ae')
+source=(https://github.com/Backblaze/${_pkgname}/archive/v${pkgver}.tar.gz)
+sha256sums=('80d2daeaee38178a4d76922da2e69d7ad1f0d90fccea90d724a38909abb69b27')
build() {
cd ${srcdir}/${_pkgname}-${pkgver}