summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Manna2021-04-03 16:16:29 -0700
committerKyle Manna2021-04-03 16:17:00 -0700
commit847e2a3661eb817952d7a6425a50c12f77f224b4 (patch)
tree54e64ee91b958669047620abd76051ab8241935a
parent6bcdd5dcb5827c6b24a20e715b7cd6c9894fc6b5 (diff)
downloadaur-847e2a3661eb817952d7a6425a50c12f77f224b4.tar.gz
release: python-b2sdk v1.5.0-1
* This package has been pleasantly cleaned-up.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 9 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe193320263d..59dfa4833089 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-b2sdk
pkgdesc = Python library to access B2 cloud storage.
- pkgver = 1.2.0
+ pkgver = 1.5.0
pkgrel = 1
url = https://github.com/Backblaze/b2-sdk-python
arch = any
@@ -11,8 +11,8 @@ pkgbase = python-b2sdk
depends = python-requests>=2.9.1
depends = python-setuptools
depends = python-tqdm>=4.5.0
- source = https://github.com/Backblaze/b2-sdk-python/archive/v1.2.0.tar.gz
- sha256sums = 80d2daeaee38178a4d76922da2e69d7ad1f0d90fccea90d724a38909abb69b27
+ source = https://files.pythonhosted.org/packages/source/b/b2sdk/b2sdk-1.5.0.tar.gz
+ sha256sums = d85a74cb7f60db676119572085cd44a61d3c383ab8e3c6836d46a15ac669db74
pkgname = python-b2sdk
diff --git a/PKGBUILD b/PKGBUILD
index f455aa881449..048f63c20806 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,8 @@
# Maintainer: Kyle Manna <kyle[at]kylemanna[d0t]com>
pkgname=python-b2sdk
-_pkgname=b2-sdk-python
-#_pkgname=b2sdk
-#pkgver=1.3.0
-pkgver=1.2.0
+_pkgname=b2sdk
+pkgver=1.5.0
pkgrel=1
pkgdesc='Python library to access B2 cloud storage.'
arch=(any)
@@ -18,16 +16,14 @@ depends=('python'
'python-tqdm>=4.5.0'
)
-#source=("https://files.pythonhosted.org/packages/source/b/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-#sha256sums=('af53e2449414b772a0bd6fad311d98a171c3693f77ebca933499946e786715ae')
-source=(https://github.com/Backblaze/${_pkgname}/archive/v${pkgver}.tar.gz)
-sha256sums=('80d2daeaee38178a4d76922da2e69d7ad1f0d90fccea90d724a38909abb69b27')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('d85a74cb7f60db676119572085cd44a61d3c383ab8e3c6836d46a15ac669db74')
build() {
cd ${srcdir}/${_pkgname}-${pkgver}
- # This requriement seems overly complex, losen the
- sed -i -e 's:\(arrow>=.*\),<0\.13.*:\1<=0.13.*:' requirements.txt
+ # This requriement seems overly complex, losen
+ sed -i -e 's:\(arrow>=.*\),.*:\1:' requirements.txt
python setup.py build
}