summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Widawsky2020-09-04 13:24:15 -0700
committerBen Widawsky2020-09-04 13:24:15 -0700
commit66820e41038509116efa936f4a7015e2efeb70e0 (patch)
treeaeabd9e6bbfe202f4f7b118db674ef1ef639cc4e
parentbbf83c0c5bcac377ddc20b84f163d1bda1ca1844 (diff)
downloadaur-66820e41038509116efa936f4a7015e2efeb70e0.tar.gz
Add license and man page
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d8bc724868e..3968865b0fa9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = python-b4
pkgdesc = A tool to work with public-inbox and patch archives
pkgver = 0.5.1
- pkgrel = 1
+ pkgrel = 2
url = https://git.kernel.org/pub/scm/utils/b4/b4.git
arch = any
license = GPL2
makedepends = python-setuptools
+ makedepends = python-docutils
depends = python
source = https://files.pythonhosted.org/packages/source/b/b4/b4-0.5.1.tar.gz
sha256sums = 7f13f2239dd942f2d14f6edf4bc9139dd0c03b6f705af00cb10abc9007eccb15
diff --git a/PKGBUILD b/PKGBUILD
index 8b4234e0c008..4a84515c76e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,11 @@ pkgbase='python-b4'
pkgname=('python-b4')
_module='b4'
pkgver='0.5.1'
-pkgrel=1
+pkgrel=2
pkgdesc="A tool to work with public-inbox and patch archives"
url="https://git.kernel.org/pub/scm/utils/b4/b4.git"
depends=('python')
-makedepends=('python-setuptools')
+makedepends=('python-setuptools' 'python-docutils')
license=('GPL2')
arch=('any')
source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
@@ -23,4 +23,8 @@ package() {
depends+=()
cd "${srcdir}/${_module}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+
+ rst2man man/b4.5.rst b4.5
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}/" COPYING
+ install -Dm644 -t "${pkgdir}/usr/share/man/man5/" b4.5
}