summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Sexton2023-06-22 05:28:25 -0400
committerMatthew Sexton2023-06-22 05:28:25 -0400
commitb6aa0063bb2058942af24339578ae3a90061d676 (patch)
tree716d3cb094a075f50d9f8fd92ed898fd0d33bc26
parente757acf63dbca027cd42bff6b2f116f60ebc7f89 (diff)
downloadaur-b6aa0063bb2058942af24339578ae3a90061d676.tar.gz
0.3.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d2ba6b3b94c5..bc7be108d21b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-baichat-py
pkgdesc = BAIChat API Python
- pkgver = 0.2.1
+ pkgver = 0.3.0
pkgrel = 1
url = https://codeberg.org/Bavarder/baichat-py
arch = any
@@ -13,7 +13,8 @@ pkgbase = python-baichat-py
makedepends = python-poetry-core
depends = python-requests
depends = python-aiohttp
- source = https://files.pythonhosted.org/packages/source/b/baichat_py/baichat_py-0.2.1.tar.gz
- sha256sums = 834de3c8d544c9724f089d7b8051bac5787d519b769cecac9054059ef559b0fb
+ depends = python-curl-cffi
+ source = https://files.pythonhosted.org/packages/source/b/baichat_py/baichat_py-0.3.0.tar.gz
+ sha256sums = 0a411ec897e6b1ffde175c40481886cbae2adca8e68eeaa209b693851c959715
pkgname = python-baichat-py
diff --git a/PKGBUILD b/PKGBUILD
index 83a7b1a83fbc..8fcae91c90af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
# Maintainer: 0xMRTT <0XMRTT@proton.me>
+# Maintainer: Matthew Sexton <matthew@Asylumtech.com>
pkgname=python-baichat-py
_name=baichat_py
-pkgver=0.2.1
+pkgver=0.3.0
pkgrel=1
pkgdesc="BAIChat API Python"
arch=('any')
url="https://codeberg.org/Bavarder/baichat-py"
license=('GPL3')
-depends=( 'python-requests' 'python-aiohttp')
+depends=( 'python-requests' 'python-aiohttp' 'python-curl-cffi')
makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel' 'python-poetry' 'python-poetry-core')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('834de3c8d544c9724f089d7b8051bac5787d519b769cecac9054059ef559b0fb')
+sha256sums=('0a411ec897e6b1ffde175c40481886cbae2adca8e68eeaa209b693851c959715')
build() {
cd "${_name}-$pkgver"