summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Botting2024-03-05 20:30:30 +1100
committerAndy Botting2024-03-05 20:30:30 +1100
commitd500dbd85dcb7c2a66fe3a842cca0644075fc5b7 (patch)
tree5bee9f33c17f82119fbcdbefb1fe0bfee2ee662f
parent72aafc6900d13a64406e820711a14a1811dba04c (diff)
downloadaur-d500dbd85dcb7c2a66fe3a842cca0644075fc5b7.tar.gz
Update to v5.7.0-1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD25
2 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 331401722ead..0cc9eff513a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-barbicanclient
pkgdesc = Client library for the Barbican Key Management API
- pkgver = 5.6.1
+ pkgver = 5.7.0
pkgrel = 1
url = https://docs.openstack.org/python-barbicanclient/
arch = any
@@ -12,6 +12,7 @@ pkgbase = python-barbicanclient
checkdepends = python-oslotest
checkdepends = python-oslo-config
checkdepends = python-openstackclient
+ makedepends = python-setuptools
depends = python-pbr
depends = python-requests
depends = python-cliff
@@ -19,7 +20,7 @@ pkgbase = python-barbicanclient
depends = python-oslo-i18n
depends = python-oslo-serialization
depends = python-oslo-utils
- source = https://opendev.org/openstack/python-barbicanclient/archive/5.6.1.tar.gz
- sha512sums = 34f1f57ea49391e1bab3d8e200475c13d061d7935b3d2c7f4e834f0d02e9ee9cdedf612fbfcef5e3686e8febdbbea1b68ff50dc8d93286337f273497d627c4d0
+ source = python-barbicanclient-5.7.0.tar.gz::https://opendev.org/openstack/python-barbicanclient/archive/5.7.0.tar.gz
+ sha512sums = 17cac8fd627789b0b1cd36f7c3c09abdb38fad238a84c159e5add291ded7d69bd88aa57ed2d41c1f30e49898460768e53b49a2fd75e9eb87235b0731bbf2bf16
pkgname = python-barbicanclient
diff --git a/PKGBUILD b/PKGBUILD
index 8eac695d0444..c31375798d26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
# Maintainer: Andy Botting <andy@andybotting.com>
pkgname=python-barbicanclient
-pkgver=5.6.1
+pkgver=5.7.0
pkgrel=1
pkgdesc='Client library for the Barbican Key Management API'
-arch=('any')
+arch=(any)
url="https://docs.openstack.org/$pkgname/"
-license=('Apache')
-depends=('python-pbr' 'python-requests' 'python-cliff'
- 'python-keystoneauth1' 'python-oslo-i18n'
- 'python-oslo-serialization' 'python-oslo-utils')
-checkdepends=('python-fixtures' 'python-requests-mock' 'python-stestr'
- 'python-testtools' 'python-oslotest' 'python-oslo-config'
- 'python-openstackclient')
-source=("https://opendev.org/openstack/$pkgname/archive/$pkgver.tar.gz")
-sha512sums=('34f1f57ea49391e1bab3d8e200475c13d061d7935b3d2c7f4e834f0d02e9ee9cdedf612fbfcef5e3686e8febdbbea1b68ff50dc8d93286337f273497d627c4d0')
+license=(Apache)
+makedepends=(python-setuptools)
+depends=(python-pbr python-requests python-cliff
+ python-keystoneauth1 python-oslo-i18n
+ python-oslo-serialization python-oslo-utils)
+checkdepends=(python-fixtures python-requests-mock python-stestr
+ python-testtools python-oslotest python-oslo-config
+ python-openstackclient)
+source=("$pkgname-$pkgver.tar.gz::https://opendev.org/openstack/$pkgname/archive/$pkgver.tar.gz")
+sha512sums=('17cac8fd627789b0b1cd36f7c3c09abdb38fad238a84c159e5add291ded7d69bd88aa57ed2d41c1f30e49898460768e53b49a2fd75e9eb87235b0731bbf2bf16')
export PBR_VERSION=$pkgver
@@ -34,5 +35,3 @@ package() {
cd $pkgname
python setup.py install --root="$pkgdir" --optimize=1
}
-
-# vim:set ts=2 sw=2 et: