summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-08-03 09:14:45 -0700
committerAndy Weidenbaum2015-08-03 09:14:45 -0700
commit1fec5a1ec0290f90506359ddb5bf58b58e53ba2c (patch)
treed77305e96ff8b7b91283e9d03047004ccfc5ed18
downloadaur-1fec5a1ec0290f90506359ddb5bf58b58e53ba2c.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b0090117687
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-base58
+ pkgdesc = Bitcoin-compatible Base58 and Base58Check implementation
+ pkgver = 0.2.2
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/base58
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ provides = base58
+ provides = python-base58
+ conflicts = base58
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/b/base58/base58-0.2.2.tar.gz
+ md5sums = f4295cfee48304a9c0c3366c03699b97
+ sha256sums = f1eaa4d3b6a0a55b1304deadd3ce11effa5773e3b738f51813eccbf2f7ee5b80
+
+pkgname = python-base58
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..272bfff9afed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=python-base58
+pkgver=0.2.2
+pkgrel=1
+pkgdesc="Bitcoin-compatible Base58 and Base58Check implementation"
+arch=('any')
+depends=('python')
+makedepends=('python-setuptools')
+url="https://pypi.python.org/pypi/base58"
+license=('MIT')
+options=(!emptydirs)
+source=(https://pypi.python.org/packages/source/b/${pkgname#python-}/${pkgname#python-}-$pkgver.tar.gz)
+md5sums=('f4295cfee48304a9c0c3366c03699b97')
+sha256sums=('f1eaa4d3b6a0a55b1304deadd3ce11effa5773e3b738f51813eccbf2f7ee5b80')
+provides=('base58' 'python-base58')
+conflicts=('base58')
+
+build() {
+ cd "$srcdir/${pkgname#python-}-$pkgver"
+
+ msg2 'Building...'
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname#python-}-$pkgver"
+
+ msg2 'Installing...'
+ python setup.py install --root="$pkgdir" --optimize=1
+}