summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBigfootACA2021-03-16 17:20:04 +0800
committerBigfootACA2021-03-16 17:20:04 +0800
commit02552b8d46bf1c12ca25f9a55a27588167c91a44 (patch)
treee6c702ea30fe201d28393f3bf2e616b402dc03f5
downloadaur-02552b8d46bf1c12ca25f9a55a27588167c91a44.tar.gz
reset repo and upload
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD52
3 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6595cd82e822
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = python-bashate
+ pkgdesc = A pep8 equivalent for bash scripts
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = http://docs.openstack.org/developer/bashate/
+ arch = any
+ license = Apache
+ makedepends = python
+ makedepends = python-hacking
+ makedepends = python-mock
+ makedepends = python-coverage
+ makedepends = python-discover
+ makedepends = python-fixtures
+ makedepends = python-subunit
+ makedepends = python-sphinx
+ makedepends = python-openstackdocstheme
+ makedepends = python-testtools
+ makedepends = python-stestr
+ makedepends = python-reno
+ depends = python
+ depends = python-pbr
+ depends = python-babel
+ source = https://pypi.io/packages/source/b/bashate/bashate-2.0.0.tar.gz
+ md5sums = 8143df66c83808ab25a59319da236fb1
+ sha256sums = eb990cf07c0ca09ee06f3b7eff79232a2d6eff9d2bdf141e8126efebb0521a17
+ sha512sums = f6bacddcad1077d034df0de4313b13aa24ba4c60baa456912d1f40511830a58ca118a72193d4cac358963870e097bee4b0e2ae5a7f7aec42f0ba1663180eb401
+
+pkgname = python-bashate
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fcaabd513b1a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,10 @@
+pkg
+src
+*.tar
+*.gz
+*.xz
+*.zst
+*.zip
+*.lz4
+*.lzo
+*.bz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51fc0b831c82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: BigfootACA <bigfoot@classfun.cn>
+
+_pyname=bashate
+pkgname=python-$_pyname
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="A pep8 equivalent for bash scripts"
+arch=(any)
+url="http://docs.openstack.org/developer/bashate/"
+license=(Apache)
+depends=(
+ python
+ python-pbr
+ python-babel
+)
+makedepends=(
+ python
+ python-hacking
+ python-mock
+ python-coverage
+ python-discover
+ python-fixtures
+ python-subunit
+ python-sphinx
+ python-openstackdocstheme
+ python-testtools
+ python-stestr
+ python-reno
+)
+source=(https://pypi.io/packages/source/${_pyname::1}/$_pyname/$_pyname-$pkgver.tar.gz)
+md5sums=('8143df66c83808ab25a59319da236fb1')
+sha256sums=('eb990cf07c0ca09ee06f3b7eff79232a2d6eff9d2bdf141e8126efebb0521a17')
+sha512sums=('f6bacddcad1077d034df0de4313b13aa24ba4c60baa456912d1f40511830a58ca118a72193d4cac358963870e097bee4b0e2ae5a7f7aec42f0ba1663180eb401')
+
+export PBR_VERSION=$pkgver
+
+build(){
+ cd $_pyname-$pkgver
+ python setup.py build
+}
+
+## Test was broken
+check(){
+ cd $_pyname-$pkgver
+ stestr run
+}
+
+package(){
+ cd $_pyname-$pkgver
+ python setup.py install --root "$pkgdir" --optimize=1
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}