summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHugo Osvaldo Barrera2015-06-09 02:10:12 -0300
committerHugo Osvaldo Barrera2015-06-09 02:10:12 -0300
commit48126329f28a5918bfb31a59da1f5233700b008e (patch)
tree5353e787378290b3666baeef10165e577568cd83
downloadaur-48126329f28a5918bfb31a59da1f5233700b008e.tar.gz
Initial commit.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db3083fccdb3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-basiciw
+ pkgdesc = Retrieve information such as ESSID or signal quality from wireless cards (Python module)
+ pkgver = 0.2.2
+ pkgrel = 1
+ url = https://github.com/enkore/basiciw/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = python
+ depends = wireless_tools
+ provides = basiciw-git
+ conflicts = basiciw-git
+ replaces = basiciw-git
+ source = https://pypi.python.org/packages/source/b/basiciw/basiciw-0.2.2.tar.gz
+ md5sums = bf4197a549c57c19c33a9a67d7da2eb4
+
+pkgname = python-basiciw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48ab2d9ac821
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Hugo Osvaldo Barrera <hugo@barrera.io>
+# Contributor: CJlano <cjlano+AUR.basiciw@free.fr>
+
+pkgname=python-basiciw
+_gitname=basiciw
+pkgver=0.2.2
+pkgrel=1
+pkgdesc="Retrieve information such as ESSID or signal quality from wireless cards (Python module)"
+arch=('i686' 'x86_64')
+url="https://github.com/enkore/basiciw/"
+license=('MIT')
+depends=('python' 'wireless_tools')
+makedepends=('git')
+conflicts=basiciw-git
+provides=basiciw-git
+replaces=basiciw-git
+source=("https://pypi.python.org/packages/source/b/basiciw/basiciw-$pkgver.tar.gz")
+md5sums=('bf4197a549c57c19c33a9a67d7da2eb4')
+
+package() {
+ cd "$srcdir"/$_gitname-$pkgver
+ python setup.py install --root "$pkgdir"
+
+ # Install README file
+ install -Dm644 README "${pkgdir}/usr/share/${pkgname}/README"
+}