summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Warrick2014-12-31 11:00:57 +0100
committerChris Warrick2014-12-31 11:00:57 +0100
commit010361cba83e060dcab0c42becc50c0763bac00b (patch)
treeb016f29f591e37196b36f99754735c25fa41b3d1
downloadaur-010361cba83e060dcab0c42becc50c0763bac00b.tar.gz
init python-bbcode
Signed-off-by: Chris Warrick <kwpolska@gmail.com>
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE23
-rw-r--r--PKGBUILD23
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51f554aca5a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-bbcode
+ pkgdesc = A pure python bbcode parser and formatter.
+ pkgver = 1.0.20
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/bbcode
+ arch = any
+ license = BSD
+ depends = python
+ options = !emptydirs
+ source = http://pypi.python.org/packages/source/b/bbcode/bbcode-1.0.20.tar.gz
+ source = LICENSE
+ md5sums = bb6e1147919d2e8f5f2f57d751d6a36c
+ md5sums = f013c3769d2db3f0f790d19978c5031d
+
+pkgname = python-bbcode
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..1423ee24c0aa
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,23 @@
+Copyright (c) 2011, Dan Watson.
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without modification,
+are permitted provided that the following conditions are met:
+
+ 1. Redistributions of source code must retain the above copyright notice,
+ this list of conditions and the following disclaimer.
+
+ 2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
+ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR
+ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON
+ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06746c96b1b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Chris Warrick <aur@chriswarrick.com>
+pkgname=python-bbcode
+_pyname=bbcode
+pkgver=1.0.20
+pkgrel=1
+pkgdesc='A pure python bbcode parser and formatter.'
+arch=('any')
+url='http://pypi.python.org/pypi/bbcode'
+license=('BSD')
+depends=('python')
+options=(!emptydirs)
+source=("http://pypi.python.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
+ "LICENSE")
+md5sums=('bb6e1147919d2e8f5f2f57d751d6a36c'
+ 'f013c3769d2db3f0f790d19978c5031d')
+
+package() {
+ cd "${srcdir}/${_pyname}-${pkgver}"
+ python3 setup.py install --root="${pkgdir}/" --optimize=1
+ install -D -m644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: