summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Warrick2016-07-20 17:49:54 +0200
committerChris Warrick2016-07-20 17:49:54 +0200
commit24af4467763933a8148c94db0b86d009f1ed5548 (patch)
tree5e799d17c7e482730c198ea1f530c64e0d9f3b38
parentb8112f405ce04ffbbeaff2670fffc50d84620cac (diff)
downloadaur-24af4467763933a8148c94db0b86d009f1ed5548.tar.gz
bbcode==1.0.24
Signed-off-by: Chris Warrick <kwpolska@gmail.com>
-rw-r--r--.SRCINFO10
-rw-r--r--LICENSE23
-rw-r--r--PKGBUILD12
3 files changed, 9 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5bef1ae09b72..e3b7f16181df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-bbcode
- pkgdesc = A pure python bbcode parser and formatter.
- pkgver = 1.0.22
+ pkgdesc = A pure Python BBCode parser and formatter.
+ pkgver = 1.0.24
pkgrel = 1
url = https://pypi.python.org/pypi/bbcode
arch = any
@@ -10,10 +10,8 @@ pkgbase = python-bbcode
makedepends = python-setuptools
makedepends = python2-setuptools
options = !emptydirs
- source = https://pypi.io/packages/source/b/bbcode/bbcode-1.0.22.tar.gz
- source = LICENSE
- md5sums = f42fcbb57b8526d0a7c276297e83676b
- md5sums = f013c3769d2db3f0f790d19978c5031d
+ source = https://pypi.io/packages/source/b/bbcode/bbcode-1.0.24.tar.gz
+ md5sums = 6330de51d752df3193b097aeb1af2cea
pkgname = python-bbcode
depends = python
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 1423ee24c0aa..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,23 +0,0 @@
-Copyright (c) 2011, Dan Watson.
-All rights reserved.
-
-Redistribution and use in source and binary forms, with or without modification,
-are permitted provided that the following conditions are met:
-
- 1. Redistributions of source code must retain the above copyright notice,
- this list of conditions and the following disclaimer.
-
- 2. Redistributions in binary form must reproduce the above copyright
- notice, this list of conditions and the following disclaimer in the
- documentation and/or other materials provided with the distribution.
-
-THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
-ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
-WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
-DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR
-ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
-(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
-LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON
-ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
-SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
index fbd22e091609..7e66c5b21788 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,16 @@
pkgbase=python-bbcode
pkgname=('python-bbcode' 'python2-bbcode')
_pyname=bbcode
-pkgver=1.0.22
+pkgver=1.0.24
pkgrel=1
-pkgdesc='A pure python bbcode parser and formatter.'
+pkgdesc='A pure Python BBCode parser and formatter.'
arch=('any')
url='https://pypi.python.org/pypi/bbcode'
license=('BSD')
makedepends=('python' 'python2' 'python-setuptools' 'python2-setuptools')
options=(!emptydirs)
-source=("https://pypi.io/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
- "LICENSE")
-md5sums=('f42fcbb57b8526d0a7c276297e83676b'
- 'f013c3769d2db3f0f790d19978c5031d')
+source=("https://pypi.io/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
+md5sums=('6330de51d752df3193b097aeb1af2cea')
prepare() {
cd "${srcdir}/${_pyname}-${pkgver}"
@@ -24,7 +22,7 @@ package_python-bbcode() {
depends=('python' 'python-setuptools')
cd "${srcdir}/${_pyname}-${pkgver}"
python3 setup.py install --root="${pkgdir}/" --optimize=1
- install -D -m644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgbase}/LICENSE"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgbase}/LICENSE"
}
package_python2-bbcode() {