summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2022-04-01 20:15:07 +0200
committerAntonio Rojas2022-04-01 20:15:07 +0200
commitfa62aef985b55959e75dd7af88132c42915aa988 (patch)
tree418e37a3e97d2ba39670e123873babe04f7cd6d9
downloadaur-fa62aef985b55959e75dd7af88132c42915aa988.tar.gz
import from community
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD42
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f992b5029692
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-bcj-cffi
+ pkgdesc = BCJ(Branch-Call-Jump) filter for python
+ pkgver = 0.5.1
+ pkgrel = 3
+ url = https://github.com/miurahr/bcj-cffi
+ arch = x86_64
+ license = LGPL
+ checkdepends = python-pytest
+ makedepends = python-setuptools-scm
+ depends = python-cffi
+ source = https://files.pythonhosted.org/packages/source/b/bcj-cffi/bcj-cffi-0.5.1.tar.gz
+ sha256sums = 2b4a5d1252e72bea5a5eb1e51650435825299b0e87c25ddfd21a1623514fd0cc
+ b2sums = f31161555597c477b052ad42ac42642b97788c3eb6a22cc48872429456a8665c9b810910a2a1f84c99a40135c17f7bbe0829115643f7d495d2d52cfc6c7a50b5
+
+pkgname = python-bcj-cffi
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb55b4c69cd3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Eli Schwartz <eschwartz@archlinux.org>
+
+_pkgname=bcj-cffi
+pkgname=python-bcj-cffi
+pkgver=0.5.1
+pkgrel=3
+pkgdesc="BCJ(Branch-Call-Jump) filter for python"
+arch=('x86_64')
+url="https://github.com/miurahr/${_pkgname}"
+license=('LGPL')
+depends=('python-cffi')
+makedepends=('python-setuptools-scm')
+checkdepends=('python-pytest')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('2b4a5d1252e72bea5a5eb1e51650435825299b0e87c25ddfd21a1623514fd0cc')
+b2sums=('f31161555597c477b052ad42ac42642b97788c3eb6a22cc48872429456a8665c9b810910a2a1f84c99a40135c17f7bbe0829115643f7d495d2d52cfc6c7a50b5')
+
+prepare() {
+ cd ${_pkgname}-${pkgver}
+
+ # thou shalt not force coverage reports on innocent unittest users
+ sed -i '/^addopts/d' tox.ini
+}
+
+build(){
+ cd ${_pkgname}-${pkgver}
+
+ python setup.py build
+}
+
+check() {
+ cd ${_pkgname}-${pkgver}
+
+ pythonpaths=("$PWD/build/lib.linux-$CARCH"-3*)
+ PYTHONPATH="${pythonpaths[0]}" pytest -rsx
+}
+
+package() {
+ cd ${_pkgname}-${pkgver}
+
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}