summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2024-01-07 08:38:38 +0100
committerCarl Smedstad2024-01-07 09:00:49 +0100
commitb878c5d374b73bd3f2046f64043445c4180859ee (patch)
tree5216a166e8a2fc9c9619512d050d6947fe177c81
parent511c25ff154b9c22f619b503af61bb3b413939b8 (diff)
downloadaur-b878c5d374b73bd3f2046f64043445c4180859ee.tar.gz
Publish version 0.16.4-1
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD63
3 files changed, 62 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 802468e92d53..785e2716bdb3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
pkgbase = python-beartype
- pkgdesc = Unbearably fast runtime type checking in pure Python.
- pkgver = 0.16.2
- pkgrel = 2
- url = https://pypi.org/project/beartype
+ pkgdesc = Unbearably fast near-real-time hybrid runtime-static type-checking in pure Python
+ pkgver = 0.16.4
+ pkgrel = 1
+ url = https://github.com/beartype/beartype
arch = any
license = MIT
+ checkdepends = python-pytest
makedepends = python-build
makedepends = python-installer
- makedepends = python-wheel
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python
- source = https://files.pythonhosted.org/packages/source/b/beartype/beartype-0.16.2.tar.gz
- sha256sums = 47ec1c8c3be3f999f4f9f829e8913f65926aa7e85b180d9ffd305dc78d3e7d7b
+ depends = python-numpy
+ depends = python-typing-extensions
+ source = python-beartype-0.16.4.tar.gz::https://github.com/beartype/beartype/archive/refs/tags/v0.16.4.tar.gz
+ sha256sums = ed7a8f5a02ef23f54cdb3b5c3d10d20c1af7ce9076e12ea61dcf44e6764da224
pkgname = python-beartype
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 0e35158bfd30..381eaf7b9ad8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,56 @@
+# Maintainer: Carl Smedstad <carl.smedstad at protonmail dot com>
# Maintainer: Achmad Fathoni<fathoni.id(at)gmail.com>
+
pkgname=python-beartype
-_pkgname=${pkgname:7}
-pkgver=0.16.2
-pkgrel=2
-pkgdesc="Unbearably fast runtime type checking in pure Python."
-arch=('any')
-url="https://pypi.org/project/${_pkgname}"
-license=('MIT')
-makedepends=(python-build python-installer python-wheel python-setuptools)
-depends=(python)
-source=(https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz)
-sha256sums=('47ec1c8c3be3f999f4f9f829e8913f65926aa7e85b180d9ffd305dc78d3e7d7b')
+_name=${pkgname#python-}
+pkgver=0.16.4
+pkgrel=1
+pkgdesc="Unbearably fast near-real-time hybrid runtime-static type-checking in pure Python"
+arch=(any)
+url="https://github.com/beartype/beartype"
+license=(MIT)
+depends=(
+ python
+ python-numpy
+ python-typing-extensions
+)
+makedepends=(
+ python-build
+ python-installer
+ python-setuptools
+ python-wheel
+)
+checkdepends=(python-pytest)
+
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('ed7a8f5a02ef23f54cdb3b5c3d10d20c1af7ce9076e12ea61dcf44e6764da224')
+
+_archive="$_name-$pkgver"
build() {
- cd ${srcdir}/${_pkgname}-${pkgver}
- python -m build --wheel --no-isolation
+ cd "$_archive"
+
+ python -m build --wheel --no-isolation
+}
+
+check() {
+ cd "$_archive"
+
+ pytest \
+ --deselect beartype_test/a00_unit/a90_claw/a00_core/test_claw_api.py::test_claw_api \
+ --deselect beartype_test/a00_unit/a90_claw/a90_hook/test_claw_extraprocess.py::test_claw_extraprocess_executable_submodule \
+ --deselect beartype_test/a00_unit/a90_claw/a90_hook/test_claw_extraprocess.py::test_claw_extraprocess_executable_package \
+ --deselect beartype_test/a00_unit/a90_claw/a90_hook/test_claw_intraprocess.py::test_claw_intraprocess_beartype_this_package \
+ --deselect beartype_test/a00_unit/a90_claw/a90_hook/test_claw_intraprocess.py::test_claw_intraprocess_beartype_package \
+ --deselect beartype_test/a00_unit/a90_claw/a90_hook/test_claw_intraprocess.py::test_claw_intraprocess_beartype_packages \
+ --deselect beartype_test/a00_unit/a90_claw/a90_hook/test_claw_intraprocess.py::test_claw_intraprocess_beartype_all \
+ --deselect beartype_test/a00_unit/a90_claw/a90_hook/test_claw_intraprocess.py::test_claw_intraprocess_beartyping
}
package() {
- cd ${srcdir}/${_pkgname}-${pkgver}
- python -m installer --destdir="$pkgdir" dist/*.whl
+ cd "$_archive"
+
+ python -m installer --destdir="$pkgdir" dist/*.whl
+
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
}