diff options
author | Donald Webster | 2025-01-15 18:38:31 -0800 |
---|---|---|
committer | Donald Webster | 2025-01-15 18:38:31 -0800 |
commit | 265f8129b13080135d497f9dbbc0b885fbddab07 (patch) | |
tree | 968dfb5987c59ddaf7b348729c15f5acb5a9a6c6 | |
parent | 838949cc00c0ebe761e369d3d8907e0d454252b1 (diff) | |
download | aur-265f8129b13080135d497f9dbbc0b885fbddab07.tar.gz |
Some small fixes for complaints during build.
-rw-r--r-- | .SRCINFO | 2 | ||||
-rw-r--r-- | .gitignore | 30 | ||||
-rw-r--r-- | PKGBUILD | 14 | ||||
-rw-r--r-- | small_fixes.patch | 26 |
4 files changed, 43 insertions, 29 deletions
@@ -8,6 +8,8 @@ pkgbase = python-bencodepy makedepends = python-setuptools depends = python source = https://files.pythonhosted.org/packages/source/b/bencode.py/bencode.py-4.0.0.tar.gz + source = small_fixes.patch sha256sums = 2a24ccda1725a51a650893d0b63260138359eaa299bb6e7a09961350a2a6e05c + sha256sums = 09673b21c54864ad746e8af7f729d2a314a4665e78be9aa4f21f078d33b3e465 pkgname = python-bencodepy diff --git a/.gitignore b/.gitignore index 43316bc3c124..6e570bc49abe 100644 --- a/.gitignore +++ b/.gitignore @@ -1,27 +1,5 @@ -# From: https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore - -*.tar -*.tar.* -*.zip -*.tgz +*.xz +*.gz *.log -*.log.* -*.sig - -# makepkg working folders -pkg -src - -# -# Additional ignore patterns: -# - -# Source files -*.deb -*.gem -*.out -*.rpm -*.html - -# Ignore package source folders -*/* +/src/ +/pkg/ @@ -11,12 +11,20 @@ url="https://github.com/eweast/$_pkgname" license=('GPL') depends=('python') makedepends=('python-setuptools') -source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz") -sha256sums=('2a24ccda1725a51a650893d0b63260138359eaa299bb6e7a09961350a2a6e05c') +source=( + "https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz" + 'small_fixes.patch' +) +sha256sums=('2a24ccda1725a51a650893d0b63260138359eaa299bb6e7a09961350a2a6e05c' + '09673b21c54864ad746e8af7f729d2a314a4665e78be9aa4f21f078d33b3e465') + +prepare() { + patch -d "$_name-$pkgver" -N -i ../small_fixes.patch +} build() { cd "$_name-$pkgver" - GIT_DIR='.' python -m build --wheel --no-isolation + python -m build --wheel --no-isolation } package() { diff --git a/small_fixes.patch b/small_fixes.patch new file mode 100644 index 000000000000..77b5421856de --- /dev/null +++ b/small_fixes.patch @@ -0,0 +1,26 @@ +--- setup.cfg.orig 2025-01-15 18:21:10.719708304 -0800 ++++ setup.cfg 2025-01-15 18:31:46.511411011 -0800 +@@ -1,10 +1,10 @@ + [metadata]
+ name = bencode.py
+ author = Dean Gardiner
+-author-email = me@dgardiner.net
++author_email = me@dgardiner.net
+ summary = Simple bencode parser (for Python 2, Python 3 and PyPy)
+-description-file = README.rst
+-home-page = https://github.com/fuzeman/bencode.py
++description_file = README.rst
++home_page = https://github.com/fuzeman/bencode.py
+ license = BitTorrent Open Source License
+ classifier =
+ Development Status :: 5 - Production/Stable
+@@ -30,9 +30,6 @@ + bencode
+ bencodepy
+
+-[bdist_wheel]
+-universal = 1
+-
+ [pbr]
+ skip_changelog = true
+ skip_git_sdist = 1
|