summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornomisge2023-08-06 16:53:35 +0200
committernomisge2023-08-06 16:53:35 +0200
commit0e5211b60fee518404e194980c23e9a9ac4bdc51 (patch)
tree960922b459ddfe80273aefa4a87045bc9eee912a
parent94f07fa6ec4799f5b4430dcef390fe544f385607 (diff)
downloadaur-0e5211b60fee518404e194980c23e9a9ac4bdc51.tar.gz
Changed source url, other minor changes
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD25
2 files changed, 21 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04a55a3bfcdc..b42d678d1a28 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = python-better-exceptions
pkgdesc = Pretty and helpful exceptions, automatically
pkgver = 0.3.3
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/Qix-/better-exceptions
arch = any
license = MIT
+ checkdepends = python-pytest
makedepends = python-build
makedepends = python-installer
makedepends = python-setuptools
makedepends = python-wheel
depends = python
- source = python-better-exceptions-0.3.3.tar.gz::https://files.pythonhosted.org/packages/source/b/better-exceptions/better_exceptions-0.3.3.tar.gz
+ source = python-better-exceptions-0.3.3.tar.gz::https://github.com/Qix-/better-exceptions/archive/refs/tags/0.3.3.tar.gz
sha256sums = e4e6bc18444d5f04e6e894b10381e5e921d3d544240418162c7db57e9eb3453b
pkgname = python-better-exceptions
diff --git a/PKGBUILD b/PKGBUILD
index b7c26a907f2d..c562e32bdc19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,31 +3,42 @@
# Contributor: Andrew Steinke <rkcf@rkcf.me>
# Contributor: mdraw.gh at gmail dot com
-pkgname=python-better-exceptions
+_name=better-exceptions
+_old_name=better_exceptions
+pkgname=python-${_name}
pkgver=0.3.3
-pkgrel=3
+pkgrel=4
pkgdesc="Pretty and helpful exceptions, automatically"
arch=('any')
-url='https://github.com/Qix-/better-exceptions'
+url="https://github.com/Qix-/${_name}"
license=('MIT')
depends=('python')
makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
-source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/b/better-exceptions/better_exceptions-$pkgver.tar.gz")
+checkdepends=(
+ 'python-pytest'
+)
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
sha256sums=('e4e6bc18444d5f04e6e894b10381e5e921d3d544240418162c7db57e9eb3453b')
build() {
- cd "better_exceptions-$pkgver"
+ cd "${_old_name}-${pkgver}"
python -m build --wheel --no-isolation
}
+# Tests are failing, probably cause of upstream errors.
+#check() {
+# cd "${srcdir}/${_name}-${pkgver}"
+# python -m pytest -s test
+#}
+
package() {
- cd "better_exceptions-$pkgver"
+ cd "${_name}-${pkgver}"
PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
install -d "$pkgdir/usr/share/licenses/$pkgname/"
ln -s \
- "$_site/better_exceptions-$pkgver.dist-info/LICENSE.txt" \
+ "$_site/${_old_name}-$pkgver.dist-info/LICENSE.txt" \
"$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}