summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormdraw2017-03-27 21:54:42 +0200
committermdraw2017-03-27 21:58:39 +0200
commite7f9d08496fff3f7cf5e2c0e359eaeab2af3f041 (patch)
tree6cffb26575f53a43ffc147c83ad7ac092ed12782
downloadaur-e7f9d08496fff3f7cf5e2c0e359eaeab2af3f041.tar.gz
Initial commit: 0.1.5
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD29
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..684ae87e23cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Mon Mar 27 19:58:30 UTC 2017
+pkgbase = python-better-exceptions
+ pkgdesc = Pretty and useful exceptions in Python, automatically
+ pkgver = 0.1.5
+ pkgrel = 1
+ url = https://github.com/Qix-/better-exceptions
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ depends = python
+ conflicts = python-better-exceptions-git
+ source = https://github.com/Qix-/better-exceptions/archive/0.1.5.tar.gz
+ sha256sums = 3004dc50446731db317cf2ef97047f03c51b329fae0c06a27b5338415bea03d8
+
+pkgname = python-better-exceptions
+
+pkgname = python2-better-exceptions
+ depends = python2
+ conflicts = python2-better-exceptions-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..63e311ad3cd2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: mdraw.gh at gmail dot com
+
+_pkgbase='better-exceptions'
+pkgbase='python-better-exceptions'
+pkgname=('python-better-exceptions' 'python2-better-exceptions')
+pkgver='0.1.5'
+pkgrel=1
+pkgdesc="Pretty and useful exceptions in Python, automatically"
+arch=('any')
+url='https://github.com/Qix-/better-exceptions'
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools' 'python2-setuptools')
+conflicts=('python-better-exceptions-git')
+source=("https://github.com/Qix-/better-exceptions/archive/${pkgver}.tar.gz")
+sha256sums=('3004dc50446731db317cf2ef97047f03c51b329fae0c06a27b5338415bea03d8')
+
+package_python-better-exceptions() {
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}
+
+package_python2-better-exceptions() {
+ depends=('python2')
+ conflicts=('python2-better-exceptions-git')
+
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+}