summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-08-22 17:45:35 -0500
committerCarlos Aznarán Laos2023-08-22 17:45:35 -0500
commitc8c50ec59ac505447b324c8ab707287e47648793 (patch)
tree6100c52b0e650ff22a91d4afe126245bc8d86422
parentcbebd6e9b3455b5bf22a963e591de3570977ad25 (diff)
downloadaur-c8c50ec59ac505447b324c8ab707287e47648793.tar.gz
Add optional dependencies
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
2 files changed, 10 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ed4670adc11..f2d99191d8da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,12 +9,17 @@ pkgbase = python-bezier
checkdepends = python-scipy
checkdepends = python-sympy
checkdepends = python-matplotlib
+ checkdepends = python-seaborn
makedepends = python-build
makedepends = python-installer
makedepends = python-setuptools
makedepends = python-wheel
depends = bezier
depends = python-numpy
+ optdepends = python-matplotlib: for plot helper support
+ optdepends = python-seaborn: for plot helper support
+ optdepends = python-scipy: for convex hull support
+ optdepends = python-sympy: for symbolic support
source = bezier-2023.7.28.tar.gz::https://github.com/dhermes/bezier/archive/2023.7.28.tar.gz
sha512sums = beec5c3c9f903a81f02cb491a6c0abdf5d0ad8fb0b9a19a30403113b68b4eee1968c2a4ed1e1dbd4b90e9b35316865cbc6350a6799251a1b087c333117dc5492
diff --git a/PKGBUILD b/PKGBUILD
index 3a7ab2b8c38b..7d34c6f8be49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,11 @@ url="https://github.com/dhermes/${_base}"
license=(Apache)
depends=(${_base} python-numpy)
makedepends=(python-build python-installer python-setuptools python-wheel)
-checkdepends=(python-pytest python-scipy python-sympy python-matplotlib)
+checkdepends=(python-pytest python-scipy python-sympy python-matplotlib python-seaborn)
+optdepends=('python-matplotlib: for plot helper support'
+ 'python-seaborn: for plot helper support'
+ 'python-scipy: for convex hull support'
+ 'python-sympy: for symbolic support')
source=(${_base}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
sha512sums=('beec5c3c9f903a81f02cb491a6c0abdf5d0ad8fb0b9a19a30403113b68b4eee1968c2a4ed1e1dbd4b90e9b35316865cbc6350a6799251a1b087c333117dc5492')