summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2022-03-25 17:18:34 +0300
committerCaleb Maclennan2022-03-25 17:18:34 +0300
commitbd449c515af89ff61119350e3924f56dee7a0af7 (patch)
treebfb9a9cefd745cdf2576103bbf089c12eda3485a
downloadaur-bd449c515af89ff61119350e3924f56dee7a0af7.tar.gz
Initial upload: python-beziers 0.4.0-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..81afe8f6a976
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-beziers
+ pkgdesc = Routines for extracting information from font glyphs
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://github.com/simoncozens/beziers
+ arch = any
+ license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/b/beziers/beziers-0.4.0.tar.gz
+ sha256sums = 3a01994887928971fd88b34777dea42ff49813264d8ffddee909310d03959ef5
+
+pkgname = python-beziers
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8350ed304d5b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+pkgname=python-beziers
+_pyname=${pkgname#python-}
+pkgver=0.4.0
+pkgrel=1
+pkgdesc='Routines for extracting information from font glyphs'
+arch=(any)
+url="https://github.com/simoncozens/$_pyname"
+license=(MIT)
+depends=(python)
+makedepends=(python-{build,installer}
+ python-setuptools
+ python-wheel)
+_archive="$_pyname-$pkgver"
+source=("https://files.pythonhosted.org/packages/source/${_pyname::1}/$_pyname/$_archive.tar.gz")
+sha256sums=('3a01994887928971fd88b34777dea42ff49813264d8ffddee909310d03959ef5')
+
+build() {
+ cd "$_archive"
+ python -m build -wn
+}
+
+package() {
+ cd "$_archive"
+ python -m installer -d "$pkgdir" dist/*.whl
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
+}