summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortinywrkb2022-03-30 17:01:35 +0300
committertinywrkb2022-03-30 17:01:35 +0300
commit860f0ab49c42efe9c5f96c3b15e07ffcc21481f7 (patch)
tree720f9ab98d5c1e184bdd4322ff6b1ebd762152f6
parentc0f1aab2d7d2121d8bd306f6d2460e45727e740b (diff)
downloadaur-860f0ab49c42efe9c5f96c3b15e07ffcc21481f7.tar.gz
bump to 0.4.2-4: follow the latest packaging guidelines
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6feb2e51b3c..f2877c98a377 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,14 @@
pkgbase = python-bidi
pkgdesc = BIDI algorithm related functions
pkgver = 0.4.2
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/MeirKriheli/python-bidi
arch = any
license = LGPL3
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
depends = python
source = https://github.com/MeirKriheli/python-bidi/archive/v0.4.2/python-bidi-0.4.2.tar.gz
sha256sums = 937295ce1369a329fabd6152be4212d6a4d80d6c278846580eabde0c1dd33077
diff --git a/PKGBUILD b/PKGBUILD
index eb9fe50378b1..4223a4717997 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,21 +4,22 @@
pkgname=python-bidi
pkgver=0.4.2
-pkgrel=3
+pkgrel=4
pkgdesc="BIDI algorithm related functions"
url="https://github.com/MeirKriheli/python-bidi"
-license=('LGPL3')
-arch=('any')
-depends=('python')
+license=(LGPL3)
+arch=(any)
+depends=(python)
+makedepends=(python-build python-installer python-setuptools python-wheel)
source=("https://github.com/MeirKriheli/python-bidi/archive/v${pkgver}/python-bidi-${pkgver}.tar.gz")
sha256sums=('937295ce1369a329fabd6152be4212d6a4d80d6c278846580eabde0c1dd33077')
build() {
cd python-bidi-${pkgver}
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd python-bidi-${pkgver}
- python setup.py install --skip-build --root="$pkgdir" --prefix=/usr --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}