summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortinywrkb2021-12-24 06:07:07 +0200
committertinywrkb2021-12-24 06:07:07 +0200
commitc0f1aab2d7d2121d8bd306f6d2460e45727e740b (patch)
treeea7c892247f51cf195c3aebfa269971b6fa0936f
parent44aa229844891427b0fcb71c72e2534a74e2166b (diff)
downloadaur-c0f1aab2d7d2121d8bd306f6d2460e45727e740b.tar.gz
Bump to 0.4.2-3: Bring back the package
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD29
3 files changed, 19 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ef4f8a65bc6..e6feb2e51b3c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,12 @@
pkgbase = python-bidi
pkgdesc = BIDI algorithm related functions
pkgver = 0.4.2
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/MeirKriheli/python-bidi
arch = any
- license = LGPL
- makedepends = python-setuptools
- depends = python-wheel
- options = !emptydirs
- source = https://github.com/MeirKriheli/python-bidi/archive/v0.4.2.tar.gz
- md5sums = 52477f00edf4dfab666988d126684f86
+ license = LGPL3
+ depends = python
+ source = https://github.com/MeirKriheli/python-bidi/archive/v0.4.2/python-bidi-0.4.2.tar.gz
+ sha256sums = 937295ce1369a329fabd6152be4212d6a4d80d6c278846580eabde0c1dd33077
pkgname = python-bidi
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b6cb52fe0037
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*/**
+*.tar*
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index 0cb18fa62117..eb9fe50378b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,24 @@
-# Maintainer: Johannes Titz <johannes.titz@gmail.com>
+# Maintainer: tinywrkb <tinywrkb@gmail.com>
+# Contributor: Johannes Titz <johannes.titz@gmail.com>
# Contributor: Doron Behar <doron.behar@gmail.com>
pkgname=python-bidi
-_pkgname=bidi
pkgver=0.4.2
-pkgrel=2
+pkgrel=3
pkgdesc="BIDI algorithm related functions"
-arch=('any')
-makedepends=('python-setuptools')
-depends=('python-wheel')
url="https://github.com/MeirKriheli/python-bidi"
-license=('LGPL')
-options=(!emptydirs)
-source=(https://github.com/MeirKriheli/python-bidi/archive/v${pkgver}.tar.gz)
-md5sums=('52477f00edf4dfab666988d126684f86')
+license=('LGPL3')
+arch=('any')
+depends=('python')
+source=("https://github.com/MeirKriheli/python-bidi/archive/v${pkgver}/python-bidi-${pkgver}.tar.gz")
+sha256sums=('937295ce1369a329fabd6152be4212d6a4d80d6c278846580eabde0c1dd33077')
build() {
- cd "$srcdir/$pkgname-$pkgver"
-
- msg 'Building...'
+ cd python-bidi-${pkgver}
python setup.py build
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
-
- msg 'Installing...'
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd python-bidi-${pkgver}
+ python setup.py install --skip-build --root="$pkgdir" --prefix=/usr --optimize=1
}
-# vim:set ts=2 sw=2 et: