summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGitHub Action2022-11-15 09:05:20 +0000
committerGitHub Action2022-11-15 09:05:20 +0000
commit9083c6c56f65e083956001de56830acdc41ec5e2 (patch)
tree894bfe6e51791b44101ecf644aa92f124c49e3b7
parent9e3071ef4724cb21c34638557f170b7c0851fc20 (diff)
downloadaur-9083c6c56f65e083956001de56830acdc41ec5e2.tar.gz
Update from GitHub Actions: python-biliass: fallback to setuptools
I don't know why but the new installing method is broken. https://github.com/ouuan/AUR-packages/actions/runs/3468943184
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67684cdbf30d..454a5713bf59 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,11 @@
pkgbase = python-biliass
pkgdesc = 将 B 站 XML/protobuf 弹幕转换为 ASS 弹幕
pkgver = 1.3.7
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/yutto-dev/biliass
arch = any
license = GPL3
- makedepends = python-build
- makedepends = python-installer
- makedepends = python-wheel
- makedepends = python-poetry-core
+ makedepends = python-setuptools
depends = python-protobuf
source = https://pypi.io/packages/source/b/biliass/biliass-1.3.7.tar.gz
sha256sums = 3fb2b76edf0c5c3e87a09eddb90f651bdf728f4955c27f52a84102fd352e74ae
diff --git a/PKGBUILD b/PKGBUILD
index 473182379414..94aeffb4346d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,22 @@
pkgname=python-biliass
_pypiname=biliass
pkgver=1.3.7
-pkgrel=1
+pkgrel=2
pkgdesc='将 B 站 XML/protobuf 弹幕转换为 ASS 弹幕'
arch=('any')
url='https://github.com/yutto-dev/biliass'
license=('GPL3')
depends=('python-protobuf')
-makedepends=(python-build python-installer python-wheel python-poetry-core)
+makedepends=('python-setuptools')
source=("https://pypi.io/packages/source/${_pypiname:0:1}/$_pypiname/$_pypiname-$pkgver.tar.gz")
sha256sums=('3fb2b76edf0c5c3e87a09eddb90f651bdf728f4955c27f52a84102fd352e74ae')
build() {
cd "$_pypiname-$pkgver"
- python -m build --wheel --no-isolation
+ python setup.py build
}
package() {
cd "$_pypiname-$pkgver"
- python -m installer --destdir="$pkgdir" dist/*.whl
+ python setup.py install --root="$pkgdir" --optimize=1
}