summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0b1001002021-10-05 15:40:09 +0200
committer0b1001002021-10-05 15:40:09 +0200
commit851858d444f2947754344d20c18be2eca9c4517d (patch)
tree91ab4934083009407cd58e87bd3730b32ed67e54
parent882a4149a2c7bfb8979a4bfed76af3f2ae21ed0b (diff)
downloadaur-851858d444f2947754344d20c18be2eca9c4517d.tar.gz
Add package relations and change license file permissions
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD24
2 files changed, 17 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22cb1b22ea53..87e02dd910a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-binance-git
- pkgdesc = simple python interface to binance.com's web API
- pkgver = 1.0.15.r0.gd76df56
+ pkgdesc = An unofficial Python wrapper for the Binance exchange REST API
+ pkgver = 1.0.15.r2.g217f1e2
pkgrel = 1
url = https://github.com/sammchardy/python-binance
arch = any
@@ -13,7 +13,9 @@ pkgbase = python-binance-git
depends = python-requests
depends = python-ujson
depends = python-websockets=9.1
+ provides = python-binance
+ conflicts = python-binance
source = git+https://github.com/sammchardy/python-binance.git
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = python-binance-git
diff --git a/PKGBUILD b/PKGBUILD
index da1857a6c10e..901610d36471 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,33 @@
# Contributor: Lex Black <autumn-wind@web.de>
# Contributor: Eric Toombs
-_pkgname='python-binance'
-pkgname="$_pkgname-git"
-pkgver=1.0.15.r0.gd76df56
+pkgname=python-binance-git
+pkgver=1.0.15.r2.g217f1e2
pkgrel=1
-pkgdesc="simple python interface to binance.com's web API"
+pkgdesc="An unofficial Python wrapper for the Binance exchange REST API"
arch=('any')
-url='https://github.com/sammchardy/python-binance'
+url="https://github.com/sammchardy/python-binance"
license=('MIT')
depends=('python' 'python-aiohttp' 'python-dateparser'
'python-requests' 'python-ujson' 'python-websockets=9.1')
makedepends=('git' 'python-setuptools')
-source=('git+https://github.com/sammchardy/python-binance.git')
-md5sums=('SKIP')
-
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+https://github.com/sammchardy/${pkgname%-git}.git")
+sha256sums=('SKIP')
pkgver() {
- cd "$_pkgname"
+ cd "${pkgname%-git}"
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/v//'
}
build() {
- cd "$_pkgname"
+ cd "${pkgname%-git}"
python setup.py build
}
package() {
- cd "$_pkgname"
+ cd "${pkgname%-git}"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- install -D 'LICENSE' "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname%-git}/LICENSE"
}