summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-02-06 18:04:50 +0000
committerGrey Christoforo2019-02-06 18:04:50 +0000
commitabb1764ffb3fb5c05f5b29e83bf7488129fb538b (patch)
tree52991ff04a5f4a1379387df63c3ad0c6689f2c00
downloadaur-abb1764ffb3fb5c05f5b29e83bf7488129fb538b.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f1e5db83dce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-biom-format
+ pkgdesc = The Biological Observation Matrix (BIOM) Format Project
+ pkgver = 2.1.7
+ pkgrel = 1
+ url = http://biom-format.org
+ arch = any
+ license = BSD 3-Clause License
+ makedepends = python-setuptools
+ depends = python-numpy
+ depends = python-click
+ depends = python-future
+ depends = python-scipy
+ depends = python-pandas
+ depends = python-six
+ depends = python-h5py
+ source = https://github.com/biocore/biom-format/archive/2.1.7.tar.gz
+ sha256sums = 88b3ef16fd7d16f4e125f1e0d356aaad4c7c281ea3fb746c0f8dc26f3a5b6d4d
+
+pkgname = python-biom-format
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..574a8578368c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src
+/pkg
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..24d591460d93
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+
+pkgname=python-biom-format
+_pkgname=biom-format
+pkgver=2.1.7
+pkgrel=1
+pkgdesc="The Biological Observation Matrix (BIOM) Format Project"
+arch=('any')
+url="http://biom-format.org"
+license=('BSD 3-Clause License')
+depends=('python-numpy' 'python-click' 'python-future' 'python-scipy' 'python-pandas' 'python-six' 'python-h5py')
+makedepends=('python-setuptools')
+source=("https://github.com/biocore/${_pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('88b3ef16fd7d16f4e125f1e0d356aaad4c7c281ea3fb746c0f8dc26f3a5b6d4d')
+
+prepare(){
+ cd "$srcdir/$_pkgname-$pkgver"
+ find . -iname "*.pyx" | xargs -n 1 cython
+}
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+
+package(){
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:ts=2:sw=2:et: