summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2018-11-16 10:47:01 -0600
committerDan Beste2018-11-16 10:47:01 -0600
commit58f50cc0c4a0256778765a66c9cc3b4eef59d27b (patch)
treeb9c927b3834537e13296e7cc0302098df04edeac
downloadaur-58f50cc0c4a0256778765a66c9cc3b4eef59d27b.tar.gz
Initial upload: python-black-git 18.9b0.r13.ge4e59f8-1
* Renamed package: black-git -> python-black-git * Re-added unit tests. * Changed python-setuptools to a dependency. * Added python-aiohttp to checkdepends.
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD46
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de92ffef09e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-black-git
+ pkgdesc = Uncompromising code formatter
+ pkgver = 18.9b0.r13.ge4e59f8
+ pkgrel = 1
+ url = https://github.com/ambv/black
+ arch = any
+ license = MIT
+ checkdepends = python-aiohttp
+ makedepends = git
+ depends = python-appdirs
+ depends = python-attrs
+ depends = python-click
+ depends = python-setuptools
+ depends = python-toml
+ provides = python-black
+ conflicts = python-black
+ source = python-black-git::git+https://github.com/ambv/black.git
+ sha256sums = SKIP
+
+pkgname = python-black-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bc9028b62ecb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Blacklist:
+*
+
+# Whitelist:
+!.SRCINFO
+!.gitignore
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7f483ff36c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Dan Beste <Dan.Ray.Beste@gmail.com>
+# Maintainer: Daniel M. Capella <polycitizen@gmail.com>
+
+pkgname='python-black-git'
+pkgver=18.9b0.r13.ge4e59f8
+pkgrel=1
+pkgdesc='Uncompromising code formatter'
+arch=('any')
+url='https://github.com/ambv/black'
+license=('MIT')
+depends=('python-appdirs' 'python-attrs' 'python-click' 'python-setuptools'
+ 'python-toml')
+checkdepends=('python-aiohttp')
+makedepends=('git')
+provides=("${pkgname/-git}")
+conflicts=("${pkgname/-git}")
+source=("${pkgname}::git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+
+ git describe --long --tags \
+ | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname}"
+
+ python setup.py build
+}
+
+check() {
+ cd "${pkgname}"
+
+ python -m unittest tests/test_black.py
+}
+
+package() {
+ cd "${pkgname}"
+
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: