summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenneth Endfinger2020-01-14 22:40:18 -0500
committerKenneth Endfinger2020-01-14 22:40:18 -0500
commit5093181755df4da8ef330275e935a898672a0480 (patch)
treedf555f0fe6e9e820b99af2c8fa6e67eaf26b3b96
parentb7625e940080ae291e3c5a79694ed65efdc08311 (diff)
downloadaur-5093181755df4da8ef330275e935a898672a0480.tar.gz
Use make instead of just python-setuptools for build.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37918200353e..7574b091ece5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-blivet
pkgdesc = A DBus service and python module for management of the system storage configuration
pkgver = 3.1.6
- pkgrel = 3
+ pkgrel = 4
url = https://fedoraproject.org/wiki/Blivet
arch = any
license = LGPL2.1
@@ -9,6 +9,7 @@ pkgbase = python-blivet
checkdepends = python-mock
checkdepends = python-dbus
makedepends = python-setuptools
+ makedepends = make
depends = python
depends = python-six
depends = python-pyparted
diff --git a/PKGBUILD b/PKGBUILD
index 5e0d67c785f2..a3022000152c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=python-blivet
pkgver=3.1.6
_tag="blivet-${pkgver}"
-pkgrel=3
+pkgrel=4
pkgdesc='A DBus service and python module for management of the system storage configuration'
arch=('any')
license=('LGPL2.1')
@@ -22,15 +22,20 @@ depends=('python'
'systemd-libs'
)
checkdepends=('libselinux' 'python-mock' 'python-dbus')
-makedepends=('python-setuptools')
+makedepends=('python-setuptools' 'make')
url='https://fedoraproject.org/wiki/Blivet'
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/storaged-project/blivet/archive/blivet-${pkgver}.tar.gz")
sha512sums=('43a4233fcc696bb050ec5b9b3f2947efd2b6116409aa13025d09e99af2c9ef02df48e7e3087c2e4e2670c2ce2d0aa6587602c41e1af98f956bcf80f03464a622')
+build() {
+ cd "${srcdir}/blivet-${_tag}"
+ make
+}
+
package() {
- cd "${srcdir}/blivet-${_tag}/"
+ cd "${srcdir}/blivet-${_tag}"
- python setup.py install --root="${pkgdir}/" --optimize=1
+ make DESTDIR="${pkgdir}" install
}
check() {