summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2022-09-29 23:35:23 +0000
committerPellegrino Prevete2022-09-29 23:35:23 +0000
commitc3f5ff84e8e8cc667b2438f626c1f6be147081e3 (patch)
treec46ad49e6b828ac02edf4601cb62e21e360e850a
parentcd048c3f0be812d7671e8c0b6e04dff162706a61 (diff)
downloadaur-c3f5ff84e8e8cc667b2438f626c1f6be147081e3.tar.gz
upgrade PKGBUILD
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD8
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d355d651f843..8d789525b8d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,11 @@
pkgbase = python-blivet-git
pkgdesc = a python module for management of a system storage configuration - python 3.x pkg
- pkgver = bf9b55b
- pkgrel = 2
+ pkgver = blivet+2.0.2+1+r1649+gbadffc78
+ pkgrel = 1
url = http://fedoraproject.org/wiki/Blivet
- arch = any
+ arch = x86_64
+ arch = i686
+ arch = pentium4
license = LGPL2.1
depends = multipath-tools
depends = mpathconf
@@ -15,8 +17,9 @@ pkgbase = python-blivet-git
depends = hawkey
depends = python-pyparted
depends = python-pykickstart
+ provides = python-blivet
+ conflicts = python-blivet
source = git+https://github.com/storaged-project/blivet.git
sha256sums = SKIP
pkgname = python-blivet-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 47a3952cd36d..c80e78c025ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
_pkg="blivet"
_pkgname="python-${_pkg}"
pkgname="${_pkgname}-git"
-pkgver=bf9b55b
-pkgrel=2
+pkgver=blivet+2.0.2+1+r1649+gbadffc78
+pkgrel=1
pkgdesc='a python module for management of a system storage configuration - python 3.x pkg'
arch=('x86_64' 'i686' 'pentium4')
depends=('multipath-tools' 'mpathconf' 'mdadm' 'libblockdev' 'libselinux'
@@ -19,12 +19,12 @@ source=("git+https://github.com/storaged-project/${_pkg}.git")
sha256sums=('SKIP')
pkgver() {
- cd "${_pkgbase}"
+ cd "${_pkg}" || exit
git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
}
# shellcheck disable=SC2154
package() {
- cd "${srcdir}/$_pkg" || exit
+ cd "${srcdir}/${_pkg}" || exit
python setup.py install --root="${pkgdir}/" --optimize=1
}